Building Horizontal Alignments

Chapter 3: Building Horizontal Alignments: the Basics

Section 1 - Managing Geometry

A project’s geometry may become very complex. The design phase of a project may last for many years.
Maintaining design data for maintenance and improvement projects may be required for many years after
that. A little planning and a little foresight prior to and during the design of a project can literally reap
benefits for decades.

Communication

Whether conducting a war, having a relationship, or designing sites or roads, good communication is an
absolutely critical component to success. Poor communication resultsin confusion, wasted time, and failed
objectives. InRoads is designed to facilitate good communication.

Self-Documentation

In data management there are tremendous advantages to embedding important information about an object
within the object itself. Most objects in the InRoads data model can accept long names and descriptions.
Many functionsin InRoads reflect and report those names. Take advantage of this ability to communicate:
use good, explicit names.

Generally, 80% of the time spent designing with InRoads is spent figuring out the engineering. It might take
an extra 5% to take full advantage of the self-documentation functionality of InRoads, but it can save
tremendous amounts of time throughout a decades long life cycle.

Naming Conventions

Using good Naming Conventions saves more time than perhaps any other habit in InRoads. The more
people and companies involved and the longer the work cycle, the more important it isto communicate well.
Even on single-person projects, poor naming conventions can cause much confusion and poor decisions.

Organizing Geometry

Isthe design or congtruction partitioned into discrete phases or areas? Will there be few or many sharing the
data? Will displaying existing geometry be needed universally? Will design teams need write-permissons
only for discrete subsets of the proposed data? From a project level, how do you want to manage the
geometry? The organization of the geometry should reflect the needs of your organization or project team
and the needs of the project.

Object “ Status’
It iscritical to segregate one type of data from another in the clearest, most obvious manner. In my
experience there are a handful of discrete data types between which there should be no confusion:
Exigting
Proposed (preferred)
Proposed (alternates)
Bad (many variations, but all in need of clear quarantine).
Design your management of the InRoads data with thisin mind.

Recall that InRoads works not from graphics but from its own data. Y ou, as the Builder of the InRoads
model, must decide how you want to manage the InRoads Geometry.
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Building InRoads

An organizational plan saves time when building geometry. While InRoads has a number of management
tools such as Copy Geometry and Rename Geometry that can be used to modify and reorg e
Geometry, things proceed more smoothly when following a plan.

The highest level of Geometry organization in InRoads is the Geometry Project, céit 'ni@rdi nate
Geometry Points, Horizontal and Vertical Alignments and Superel evation definiti on%ﬁ; e unit that is
ry Pr

saved as a file on the hard drive or server. InRoads can have any number of G sopen at the

same time. i
Creating New Geometry @
t

Section 2 - Building Practice Alignments

First, snce we will be working exclusvely with Geometry this lab, let he InRoads Explorer

Workspace tab to Geometry. %

PN

1. Select the Geometry 7 InRoads [=[o]=]
tab in the InRoads File Swface Geometry Ewaluation Modeler Drafing Tool: Help |
Explorer Workspace bar. <Urnameds . BNWS W~ |8

eometry Praoje... | Dreszcription | Filz M ame
E Crefault

E Drefault

| £ Sufaces = Geometry | &« v .| |

-+
Toggles the Yiite Lock o
Create a New Geometry Project for our mnments
>
2. Select InRoads>File>New. 2.8 MNew  EEA|

N2
Surface Eeometry | Twpizal Section Lil:-rar_ul Roadway LiI:nrar_l,II

Thisformisused to create @filetypes in
InRoads. Type: IGEDmetr_l,l Froject j Apply I

M ame:

Stiles...

Harizontal Aligriment

3. Sdect the Geometry Tab. N

Diescription: Wertical Alignment

Superelevation Help

il

The Type listbox Iist@he our Geometry structures e

that can be creat g Geometry Project Curez Dfinition: H
will createanew k Geometry Project. Creating

an Align% evation definition will do Erielos Deseription

S0 in the active parent structure. For example, a [Dotoitt

new Vert ygnment will be created in the

Active alignment.

%3 N | ]

Cloze |
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Building Horizontal Alignments

% Geometry Project

= COGO Buffer (Always 1)
% Horizontal Alignment (Zero or more)
= Superelevation definitions (Zero or more)
o Horizontal Event Points (Zero or more)
% Vertical Alignment (Zero or more)
= Vertical Event Points  (Zero or more)

To create a New Geometry Project:
4. Select Geonetry Proj ect for Type. MNew  mE@EA|

S. Key In a_deSC_II’I ptive Name, such asthetitle of Surface Eeometry | Twpizal Section Lil:-rar_ul Roadway Library I
the class“Bui | di ng | nRoads”. .
6. Key in auseful Description, such as“pr oposed R |Geomety Froject =] /| Apply |
geonetry for Building | nRoads.” Harme: |Buiding_InFioads ST |

Description: Iprnpnsed georn Building In Help |

Shyle: | F] —

[Eurye et I j

Eizting Dezcrption

Default

4 | 0
Cloze |

7. Hit Apply.
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Building InRoads

Feedback:

Notice the feedback upon hitting the

Apply button:
In the New Geometry form
Building_InRoads is shown
in the Exigting [ Geometry
Project] list.
In the InRoads Explorer
“Building_InRoads’ is shown
as the Active Geometry
Project.
“Successful completion” is
displayed in the InRoads and
CADD messagefields.

"™ InRoads =[o] =

File Swface Geometry  Ewaluation  Modeler  Drafting TDD|S Help |

<Unnamed:> 5 i . |
Genmetl_l,l F'm|e | Drescription | File Name
= % Eeumetl_l,l Projects = Default
e . |=|Building_InR... proposed...
I '. Bwldlng_lnﬂoads

% Surfaces % Geometry & 4 I )I 'I I _'I

Euccessful completion I S
T New HE B

Surface  Geometry | Typical Section Libral_l,ll Roadvaay Liblar_l,JI

Dope: IGenmetr_l,J Project j
Mame: [Building_InFioads Ee |
Description: Iprnpnsed geom Building In Help |
Ghyles I j
e Defititian I j

E:-ﬂshng

Description

Close |

|
I_l Successiul completion |

~

8. Leavethe New Geometry for en. “ InRoads B E
9. In the InRoadS eXpI orer eXpa%M File Surface Geometry Ewaluation  Modeler  Drafting  Tools Help |
“Building_InRoads’ object. Unnanecd % B
10. Select the Building_InR&s in : ‘,[*‘,f'““e | inearity | ce
the Workspace pane so tha is Em% EB 'B";f;ﬁ rroweets ‘
pane will show the “children
Building_InRoads.
Q 2 Geometry Iﬂ Typical Sectic « | » | Jq | N

Q Adjusts the view to display specified cross sect_ions i
CreatingHo gnments
In this Iab e a number of discrete alignments. We will need to create an InRoads Horizontal
Alignm each. |f we can create blank alignments all at once we will have to set the appropriate
Align |ve before defining its e ements.
Align conventi on
Fay'thi e will be defining a number of “practice” alignments with little engineering meaning. Thelab
or e segregated by Letter prefixs: the first alignment will be between points A1 and A2; the second

1, B2 and B3; etc. These alignmentswill not be used in future labs. What would be an appropriate

g convention? The lab will suggest one; you are free to use something you prefer.
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11. Set the Type to Hori zontal Ai gnnent .

12. Key in“xPracti ce A’ for the alignment Name.
13. Key in a useful Description.

14. For the Style, select “cl_practice’ (for special
practice alignment symbology).

The Style controls how the alignment graphics are
displayed (settings are defined via InRoads>View
Geometry>Geometry Style Manager and stored in

Building Horizontal Alignments

THew _______ FEEA|

Surface Eeometry | Twpizal Section Lil:-rar_ul Roadway LiI:nrar_l,II

Dope:

M ame:
Descrption:
Shyle:

Curve Defintion:

I Huorizontal Alignment j Apply I

I:-cF'rau:tiu:e_.-’-‘-. Styles... |

Help |

Iprau:tiu:e alignment &,

o sctc S

. . . i . o cl_proposed
the wysiwyg.ini Stylefile). In addition to providing curtbs/walks
automatic conformance to graphics standards, the Esisting gzzg_ﬁ .
Styles can be used to provide information). =
15. Hit Apply. 1 | 2
Close |
Feedback: 7 InRoads [[o]=]
Notice the feedback upon hitti ng the File Swface Geomety Evaluation Modele.r Drafting IDE.IIS _ﬂelp |
Apply button: wrnemed> = B[ @ N ¥ ¢ W = 5% 8
In the New Geometry form iame Intedrit Description
H i H 5z, Geometry Projects e
XPI.’a!:)tl Ce—A I_S mown ”:] the E DefaujI: ! «Practice_A, Ernpty practice alignmenl
Exigting [Horizontal Alignment] B

ligt
In the InRoads Explorer
“XPractice_A” is shown asthe

Building_InRoads
“fe* Cogo Buffer

C I New

=1ofx]

Active Horizontal Alignment. In

the Results pane additional

information for “xPractice A” is
displayed.

“Successful completion” is
displayed in the InRoads and
CADD messagefields.
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[ wPractice_a Suface Geometry | Tupical Section Lihraryl Fioadway Libfal.'r'l
2 Geometry | & Typical Sec  Typs: IHorizontaIAlignment = Apply |
Successful completion Hame: |:<F'ractice_ﬁ3« Styles. .. |
Drescription; i i
L Ipractlce alignment &, Help |
Style: [dtetauit =]
Curve Definition: IA'C j

Existing

wPractice &

|

Dezcription

ractice alignment &
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Building InRoads

Building Horizontal Alignments with the Horizontal Curve Set tools.

Now that InRoads has a “ memory dot” for the alignment, we can start defining the Align L heprimary
“Build and Create” commands for horizontal alignments are found under the InRoads> orizontal
Curve Set menu and/or the Horizontal Curve Set toolbar. < &

Similar to CAD tools.
The Horizontal Curve Set tools are smilar to CAD tools

Horizontal Curve Set command MicroStation commang~._ 0CAD command
Add Pl PlaceLinestring  ~ \\|.Polyline

Insert Pl Insert Vertex (> N MPedit>Edit>Insert
Move Pl Modify Element S\ Pedit>Edit>Move
Delete Pl DeeteVertexd’/ N\ | Pedit>Edit>Straighten
Define Curve Fillet N Fillet

In its most smple form, defining an alignment can be as easy 1ng a linestring and filleting the vertices
with the proper radii. Of course, InRoads provides a great unctionality than the CAD packages.
CAD doesn't provide support for spirals (clothoids) for/tans curves nor the “unusual” practice of
using circular curvesin the horizontal plane and parabolas vertical.

For our first alignment we will smply place a single tangent from points A1 to point A2. A singleline
means two endpoints or Points of Intersection. will use the Add Pl command.

Before using this command:

Simplify and verify: It isaways a good 0 your objectsin InRoads before working. Make sure
there are no extraneous and possibly con graphicsin your working or target area. Isthe existing
condition of the alignment like you expect it toRe? In this case we are working with a brand new alignment;

it should, therefore, be empty. T%verified by Viewing or Reviewing the alignment.

Feedback during the command:
InRoads uses prompts extensiv ing the Add PI command: read the prompts! Expect “rubberbanding”
during the command.

S—
16. In the CAD file xLabHor i%@al Ai gnnent s, Zoom or Window so that A1 and A2 arevisble.

17. Select InRoads>Geometry>Horizontal Curve Set>Add PI.

Q
The Add PI command addya Point of Intersection to either end of the active alignment. It first prompts
<

> Identiy aignment end ) pie alignment is empty, a data point or precision key in istaken asthe first PI.

Otherwisé,/fh}d\K

18. Placess{datpoint near “A1” (accuracy isirrdevant at this point).

SN Al
The i&é%b%med at the datapoint (a Pl symbol may or may not be shown

SRIgggending on settings).

t isused to select which end of the alignment to “Add PI's’ to.

e,

-

loript changes to: '* Identify Faint/Reiect | | the alignment “rubber bands’ : <
) e Initial PI to the cursor, and the InRoads Explorer message field

echoes the Coordinates of the cursor:
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