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Section 2 - Placing Sump Grates and Pipes 
 How to Set Drainage Options 
 When to Set Structure Settings 
 Using Preference Sets 
 Placing Ditch Inlets 
 Placing a connecting Pipe 
 Saving the Drainage File 
 

Overview 
The Drainage database has a data model for each of the drainage structures types it 
models.  Pipes, for example, have over 70 storable attributes, inleets over sixty.  
Obviously Laying Out structures would be a very slow process if the user had to answer 
fifty questions per structure.  Typically, some attributes of a structure type remain fairly 
constant in an office or on a project.  Other data varies for every instance of a structure.  
When Laying Out structures, S&S only asks the users for the most volatile information, 
the rest it takes from pre-defined settings. 
 
Default Settings 
In implementing Storm & Sanitary, Intergraph chose to allow saving common static 
region- or project-wide data in Preference files.   This data is easily modified by the user, 
but it provides a common starting point from which to start, and can be thought of as 
Default Settings. 
 
Interactive Settings 
Structure-specific information, such as location, cannot be saved ahead of time.  This 
information must be input by the user during Lay Out of the Structure.  These can be 
thought of as the Interactive Settings. 
 
Other fields in the structure model cannot be set until later in the workflow when other 
information is provided, such as flow information.   
 
The default options are segregated into General, Design, and structure-specific areas. 
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Drainage Options form, General tab Drainage Options form, Design tab 
 
The Design tab, “Structure:” listbox, lists the four structure types.  Design settings for the 
structure types are set through this Design tab.   
 
Structure physical characteristics are set under the tab for that structure. 

Goal 1 – Setting Default Options 
The first step in laying out a structure is to make sure that S&S Design and Structure 
Defaults Settings are set properly.  General settings, such as Discharge Units or 
Hydraulic Equation, seldom change.  Other settings, such as Pipe Sizes and Inlet Types, 
tend to change many times across a network. 
 

1. Select SC>Tools>Drainage>Options.  
 
The Drainage Options form is invoked.  The General and Design tabs tend to contain 
information that changes infrequently.  Nonetheless, a quick check will only enhance 
quality. 
 
In this lab we will place two Grate Inlets in Sump condition along the centerline of the 
inverted-crown Balcony Rd.  We will also place a pipe between these two Inlets.  Before 
doing so we set the “default” settings of the inlets and the pipes.  
 
2. Select the Inlet tab of the Drainage Options form. 
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3. The active Inlet Information is displayed, which may or may not be appropriate 
for the structures we are placing.   

4. Click on the Design tab.   
5. Click on “Inlet” in the “Structure:” list. 
 

  
Default Inlet settings under the Inlet tab Default Inlet settings under the Design tab 
 

 Rather than change each individual setting individually, which requires attention to 
detail, many steps, and is subject to error after many changes to structures, let us see if an 
appropriate Preference Set is set up: 
 
6. Select the Preference…  button. 
 
The Preference form is invoked, displaying the previously-defined Preference Sets for the 
Drainage Options Dialog box. 



Storm&Sanitary Training Manual 

 

2 - 4  ©2000 Civil XLR8 

 
 
7. Select the Preference Named “Grate-Sump”. 
8. Click “Load”. 
9. “Close” the Preference form. 
 

 
 
Note: ALL the settable options in the form (not just the those visible under the active tab) 
are reset as per the Preference Set values. 
 

 Management Hint:  For relatively static settings, individually changing settings 
every time leads to greater rework and chances for random errors.  Appropriate 
Preference Sets minimize rework and changes for random errors.  Changes to incorrect or 
non-existent Preference Sets should be saved as a new Preference Set and sent to the 
“Standards Manager” for review and inclusion into the software standards. 
 
10. Verify the information in the form matches that shown here. 
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11. If you make any necessary changes, hit Apply. 
12. “Close” the form. 
 

Goal 2 – Place Sump Grates 
 
Now that we have set up our Grate Inlet defaults, let's place them. 
In our dataset we will place two Grate inlets at sump locations along the centerline of the 
inverted-crown Balcony Rd.  The leaders are linestrings which can be snapped to for 
“exact” placement. 
 
13. Select SC>Drainage>Layout  
 
The “Pipe” tab is displayed by default. 
 

 
 
 
14. Select the “Inlet” tab. 
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The “Inlet ID” value is derived from the settings defined in the Drainage Options form, 
General tab.  Duplicate ID's are not allowed.  The number is incremented to the next 
available number. 
 
The Location frame contains Northing, Easting, and [Inlet] Elevation key-in fields.  A 

locator button to the right of these fields allows the user to use select the location via 
a MicroStation Data Point <D> or Tentative Snap <T>.   
 
If the point lies within the active surface the Elevation is read from the surface.  If the 
point does not lie within the surface it reads the elevation from the active Z (which can be 
arbitrary) or from the elevation of the tentative point <T>.   
 
Note: any default offered by the SelectCAD products is editable if it is in a text (or keyin) 
field. 
 
“Angle:” refers to the placement angle of the structure (subject to defaults in Drainage 
Options>>Inlets: Absolute Angle; Parallel to Alignment, Perpendicular Alignment). 
 
“Longitudinal Slope:” and “Transverse Slope:” are used for gutter flow depth and spread 
calculations (subject to defaults in Drainage Options>>Inlets) and are more important for 
on-grade inlets. 
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The “Symbology” button invokes the View Drainage Symbology form from which the 
Inlet symbology can be set (discussed later in Chapter 3). 
 

15. Click the Locator button to the right of the Northing, Easting, and Elevation 
fields. 

16. Snap to the end of the “Grate Sump 1” leader. 
 
The form should return looking similar to the screenshot below: 
 

 
 
17. Hit Apply. 
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The inlet is placed.  
 
18. Click on the Locator button again. 
 
The Inlet ID is automatically incremented and the form disappears so that you can select 
the end of the leader at “Grate Sump 2”. 
 
19. Snap to the end of the leader at “Grate Sump 2”. 
20. Hit Apply. 
 
 

Inlet #2 (IN2) is placed.  
 
 
21. “Close” the Form. 

Goal 3 – Laying Out Pipe 
 

 Before Laying Out a different type of structure it is always a good idea to check the 
structure defaults. 
 
22. Select SC>Tools>Drainage>Options>>Pipe. 
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We want to place 12” diameter PVC pipe with 4 feet of cover. 
 
23. Change pipe “Material:” to PVC. 
24. Change pipe “Size (W x T):” to 12.00 x 0.7900 
25. Change “Minimum Cover:” to 4.00 
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Although the Pipe Size will be subject to frequent changes, let us nonetheless save a 
Preference Set for PVC pipes. 
 
26. Click the “Preferences… ” button. 
27. In the Preferences dialog box, click the “Save As” button. 
28. Key in “Pipe-PVC” in the preference “Name field. 
 

 
 
29. Click “OK”. 
30. Close the Preference form. 
31. Close the Drainage Options form. 
 
We are now ready to Lay Out Pipes.  We will connect a pipe from Inlet 1 (IN1) to the 
Inlet 2 (IN2) and a pipe from IN2 to a free-exit position (similar to an outfall pipe). 
 
32. Select SC>Drainage>Lay Out>>Pipe 
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Drainage Lay Out form, Pipe Information 
The “Pipe ID” value is derived from the settings defined in the Drainage 
Options>>General form.  Duplicate ID's are not allowed.  The number is incremented to 
the next available number. 
 
Pipe Connections 
The Location frame behaves like the location frame under inlets.  The Locator buttons 
function the same but there are two per pipe end.  Pipe ends can be either attached to a 
structure or be “free.”  Use the Locator button adjacent to the ID fields if you want to 
select a structure and the Locator button adjacent to the Northing and Easting fields if 
you want to define the location of a free end. 
 
Free-entrance and Free-exit Pipe ends (or “nodes”) can later be attached to other 
structures, including pipes.  The free end has Northing, Easting and Elevation data stored 
in the database. 
 
Locator buttons adjacent to Structure (ID) or Northing/Easting fields make selecting 
either a structure or a free-entrance/exit a click of a button. 
 

Upstream and Downstream 
Storm&Sanitary pipe layout is relatively flexible, but has one strict definition: Upstream 
and Downstream are defined from flow direction.  You can define the Upstream and 
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Downstream in either order and you can have Upstream inverts lower than the 
Downstream (adverse slope), but if you accidentally define the Upstream structure as the 
Downstream structure, S&S assumes that you know what your doing and lets you.  The 
flow will ALWAYS be from UP to Down.  The error may not show up until you Design 
your system.  
 
Inverts 
The remaining three fields are used to give the pipe invert/soffit elevations and slope.  
One field is derived from the other two.  Clicking a radio button locks the corresponding 
value.  Keying in a value in one of the remaining fields causes a recalculation in the 
other. 
 
By default, invert elevations are used for pipe elevation input.  With the “Use Soffit 
Elevations” checkbox Checked (ON), soffit elevations can be used. 
 

33. Select the Locator button  to the right of the Upstream ID field. 
34. Select the first upstream inlet, IN1, with a data button <D> (a snap/tentative 

point<T> to the structure is not necessary). 
 

 
 
The Lay Out form returns with “IN1” in the Upstream ID field and the “Invert In:” field 
containing a default elevation derived from: 

the surface elevation - the minimum cover - the pipe diameter.   
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The Northing and Easting fields display the structure's Northing and Easting values.  Free 
Entrance/Exit pipes will display “FREE_EXT” in the “ID” Field.. 
 

35. Select the Locator button  to the right of the Downstream ID field. 
36. Select the first Downstream inlet, IN2, with a data button <D>  
 
The form returns with the “IN2” in the Downstream ID field, a default value for “Invert 
Out:”, and a value for slope.   
 
The “Invert Out:” default value = the lower value of the  
       surface elevation - the minimum cover - the pipe diameter 
– -OR- 
–  (the upstream invert – (the minimum slope * the pipe length)). 
 

 
 
37. Click “Apply” to Place the pipe. 
 
The Pipe graphic is placed and a Pipe record is added to the drainage “database.”   
 

 
 



Storm&Sanitary Training Manual 

 

2 - 14  ©2000 Civil XLR8 

The Layout form is updated so that the “Pipe ID:” is incremented and the Upstream 
structure is set to the Downstream structure of the previous pipe.  The default “Invert In:” 
is the lowest invert of the upstream structure minus the “Drop Across:” field in the 
structure Drainage Option tab. 
 

 
 
For the pipe P2 we will give it a free-exit. 
 
38. Click on the Locator button to the right of the Downstream Northing and Easting. 
39. Snap to the left end of the centerline for Balcony Road. 
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The “Invert Out:” default is from the elevation of the tentative point, which is at-grade.  
Rather that accept this default, we will define the pipe slope. 
 
40. Key in “1%” or “0.01” in the slope field.  The “Invert Out:” will be recalculated. 
41. Hit Apply. 
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42. The pipe is placed. 
 

 
 
Now that some work has been done, it is a good idea to save the Drainage file. 
 
43. Select SC>File>Save>Drainage Data. 

 



Storm&Sanitary Training Manual 

©2000 Civil XLR8  2 - 17 

 


