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Introducing Storm&Sanitary 
By Jeff Martin, R.C.E., of Civil XLR8. 
http://civilxlr8.com 
 
Goals:  

• Provide a streamlined but thorough conceptual introduction to the primary Storm&Sanitary workflow. 
• Segregate the user’s steps from the narrative, so that the “button-pushing” can be performed during a 90-

minute workshop. 
1. User steps begin with a number and are border with horizontal lines. 

 
Note: this lab is quick and dirty, aimed at getting the user to “push buttons” in the most basic workflow.  For a 
full, integrated, Good Technique/Good Results Training Manual, see http://civilxlr8.com/Mastering_SnS.htm 

Section 1 Storm&Sanitary: Getting Started 

Launching S&S 
1. Select Start>Programs>Bentley Civil Engineering>InRoads Storm&Sanitary 
2. In your CAD program select the following file: 
   MicroStation:  C:\training\SnS_2002\data\SnS_2002.dgn 
  AutoCAD:  C:\training\SnS_2002\data\SnS_2002.dwg 
 
Your CAD file should look something like the screenshot below: 
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The file should be empty, with all the information in reference files. 

Setting Project Defaults 
This step helps manage the files.  “Project Defaults” is a good QA/QC tool. 
 
3. Select InRoads>Project Defaults…  

 
 
 
 
4. Click on the Configuration Name listbox. 
5. If “SnS_2002” is listed, Select it. 
6. Hit Apply. 
7. Close the form. 
 
This form is used to automatically load the primary 
settings file and to set project default directories. 
 
If “SnS_2002” is not listed under “Configuration 
Name, then:  

• Click the New…  button. 
• Key in “SnS_2002”, Hit OK. 
• Place your cursor in the Preferences (*.ini) 

field, then click the Browse button. 
• Select the following file: 

C:\training\SnS_2002\data\sns02_dgn_xl.ini 
 

• Place your cursor in the “Project Default 
Directory” field, then hit the Browse button.  
Select the project directory:  

C:\training\SnS_2002\data 
• Repeat for all the Directory paths. 
• Hit Apply. 
• Close the form. 
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Loading the Data files 
 
8. Select InRoads>File>Open 
9. In the Open form, make sure the “Files of 

type” box lists “Projects (*.rwk). 
10. Select the Project file “sns_biuc02.rwk” 
11. Hit Open. 
 
If “sns_biuc02.rwk” is not visible, verify that you are 
in the correct directory and that the “Files of type:” 
listbox displays “Projects (*.rwk)” 
 
12. Close the form. 

 
 
The .rwk file is a text file listing other files for S&S to load.  In this case, “sns_biuc02.rwk” loads a Surface 
(*.dtm), a Geometry Project (*.alg) and a Drainage database (*.sdb) 

Section 2 Laying Out Structures 

Laying Out Curb Opening Inlets 
13. Select InRoads>Drainage>Lay Out 
The Drainage Lay Out form is invoked. 
 
From this form, all Drainage structures, [Drainage] Areas, and 
[Sanitary] Zones are Created. 
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14. Click on the “Inlet” tab. 
 
The Lay Out form contains controls for those structure 
properties that change for every structure, .  More 
“permanent” properties can be checked and set from the 
“Options” button at the bottom of the form.   
 
It is good QA\QC to check the Options before placing new 
structures (while making changes is easy, it is saves time to 
verify before placing). 
 
15. Click on the Options button. 
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These are some of the less “volatile” of the settings 
available for Inlets.  These settings tend not to change 
for every structure placed.  Examples can be Inlet Types 
or Pipe Size. 
 
(Information that rarely changes tends to be stored in 
external support files.  Material tables, zoning densities 
and Intensity-Duration-Frequency tables are an 
example). 
 
Note: Storm&Sanitary recognizes five different Inlet 
Types. 
 
16. Close the Drainage Options form. 
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The Lay Out form (as well as many of the forms in InRoads 
and Storm&Sanitary) has controls called Target buttons which 
are used to get information from the CAD package.   
 
One of the properties that changes for every structure is the 
Location.  The Northing, Easting and Elevation can be keyed in 
or the adjacent Target buttons can be used to get the 
coordinates from the CAD package.  CAD Snaps/Osnaps can 
be used for precise input.  
 
Upon pressing a Target button, the form is minimized so as to 
minimize the form’s interference with the CAD view.  Upon 
selecting a location or object within the CAD file (using the 
CAD package procedure, including snaps and “verification”) 
the form returns with the information from the CAD package. 
 
Some Target buttons are adjacent to fields which require 
additional steps within the CAD package.  For example, the 
Angle Target button requires two points be placed within the 
CAD package, the angle being calculated from those two 
points. 
 
  

 
We will now place a Curb Opening Inlet along the curb of the road. 
 
17. Hit the Target button next 

to the Northing, Easting 
and Elevation fields. 

 
The form is minimized. 
 
18. Snap to the end of the line 

labeled “INLET 1”. 
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The form is restored, with Northing, Easting, and Elevation 
information from the CAD package.  Elevation is derived 
from the active surface at the Northing, Easting coordinate. 
 
Additional information is also available for review or editing. 
 
19. Hit Apply to Create the Inlet. 

 

 

 
The inlet is placed and the form is ready for the next structure. 
 
20. Hit the Target button next to the Northing, Easting and Elevation fields. 
21. Snap to the end of the “INLET 2” line. 
22. Hit Apply. 
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Laying Out a Pipe 
Let’s now Lay Out a Pipe between the Inlets 
 
23. Select the Pipe tab on the Drainage Lay Out form. 
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The Pipe Lay Out tab is similar to the Inlet tab, in 
that only the most essential input is required to 
place the pipe.   
 
Like Inlets, the Location of the pipe, both Upstream 
and Downstream ends, is required for each pipe. 
 
Note that there are Target buttons corresponding to 
Structure ID’s and Northing’s and Easting’s.   
 
Selecting a Target button next to an ID field tells 
S&S to look for an S&S Structure.   
 
When selecting a Target button next to the Northing 
and Easting fields, S&S will ignore any structure 
and get only the coordinates of the data point.  
These are known as Free-Entrance or Free-Exit 
pipes (examples can be laterals or outfall pipes). 
 
If, for example, you were to select the Target button 
next to the Upstream ID and then place a data point 
over an S&S structure, S&S would look for a 
Structure near the CAD data point.  Finding one, it 
would reflect the Structure ID in the Upstream ID 
field.  The Northing and Easting of the structure 
will also be echoed in the Northing and Easting 
fields. 
  
If you were to select the Target button next to the Northing and Easting fields and place a CAD data point in the 
same location, even directly upon an S&S Structure, S&S would return ONLY the Northing and Easting.  
Because S&S is NOT looking for a structure, it will not find one.  “FREE_ENT” or “FREE_EXT” will show in 
the ID fields. 
 
For our lab, the flow direction is from Inlet1 to Inlet2; that is, Inlet1 is the UPSTREAM Inlet and Inlet2 is the 
DOWNSTREAM Inlet.  Storm&Sanitary Lay Out is robust, but Upstream and Downstream are NOT 
interchangeable: it defines the flow direction and impacts how the system is networked. 
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Before actually Laying Out the Pipe, it is a good idea 
to see what kind of pipe you are Laying Out.   
 
24. Hit the Options button. 
 
These are the active pipe settings.  Unless we change 
any of the fields, we will be placing a 12” round 
Reinforced Concrete Pipe.   
 
Notice that minimum and maximum design 
preferences can be set here.  These numbers are used 
in calculating default invert elevations and other 
settings. 
 
25. Close the Drainage Options form. 

 
 



Introducing Storm&Sanitary  
 

©2002 Civil XLR8    11

26. Select the Target button next to the Upstream ID 
field. 

27. Place a data point on INLET1. 
28. Select the Target button next to the Downstream ID 

field. 
29. Place a data point on INLET2 
 
As the Upstream and Downstream locations are selected, 
elevation and slope information is calculated from the Inlet 
elevations and the pipe Drainage Option settings. 
 
Default Inverts and Slopes can be overwritten through the 
interface. 
 
30. Hit Apply to Lay Out the Pipe. 
 

 
 
Pipe1 is Laid Out and information in the form incremented to facilitate placing the next pipe. 
 

 
 
31. Close the Lay Out form. 
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Section 3 Editing/Reviewing, Displaying, and Deleting S&S Structures. 

Editing/Reviewing S&S Structures 
The first place to look for feedback is in the InRoads Explorer.  For example, some of the Inlet information is 
displayed in the right “feedback” panel. 
 

 
 
To review or edit detailed information of a structure,  
32. Select InRoads>Drainage>Edit/Review…   
33. At the “Key in ID or identify structure” prompt, Place a CADD data point on Inlet1 
 
Once the structure is found, the Edit/Review Inlet form is displayed.   
 
Information can be edited in this form. 
 
Structure information is broken down by type.  The first tab tends to be physical information about the structure.  
Information under other Tabs, such as Flow, will be blank until an appropriate time in the workflow, such as a 
Network Design. 
 
Information for Pipe1 can be be found by selecting the Pipe in the CAD view or by hitting the “Edit Down… ” 
button, which shows the information for the next structure downstream. 
 
Hit Apply after making any changes. 
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34. Close the form when finished. 

Displaying S&S Structures 
Like most newer database systems, the S&S “database” record for a structure contains spatial information from 
which graphics can be displayed. 
 
35. Select  InRoads>Drainage>View Drainage 
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36. Hit Apply to have the contents of the S&S database be displayed according to the settings defined in this 
form.   

 
While the WHERE comes from the data record, this form enables the user to set WHAT displays and HOW it is 
displayed.  .For example, Pipes can be displayed any combination of center line, pipe wall interior, and pipe 
exterior. The Symbology settings for Circular Manholes is shown below.  Junctions can be displayed as 
Cells/Blocks as well as a variety of other shapes. 
 

 
 
(Note:  If the InRoads Style Lock is ON, the form is not invoked and the structures are displayed according to 
InRoads feature styles assigned to each structure, which may be different). 
 

Deleting Structures 
MicroStation and AutoCAD know little about Storm&Sanitary.  Storm&Sanitary knows all about MicroStation 
and AutoCAD.  Upon Laying Out a Structure S&S creates a database record and tells the CAD package to place 
a graphic.  A CAD Delete/Erase command deletes ONLY the graphic, doing nothing to the information in the 
S&S database.  Only an S&S Delete command will delete BOTH the graphic and the data record.   
 
If a fence or region is active during this command S&S will prompt the user to confirm that all structures in the 
fence/region will be deleted. 
 
37. Use your CAD Delete/Erase command to delete one or more structures. 
38. View the Drainage Structures using InRoads>Drainage>View>Drainage Command. 
 
Notice that the “deleted” structures reappear. 
 
39. Use InRoads>Drainage>Structure>Delete to delete one or more structures. 
40. View the Drainage Structures using InRoads>Drainage>View>Drainage Command. 
 
Notice that the Deleted structures are gone. 
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Section 4 Laying Out More, Faster. 
For this section we will do more of what we did in the earlier section, but more of it, faster.   
 
We will use the “Add Connecting Pipes” function, which, 
during Inlet Lay Out, also Lays Out the pipes by a Keyed In 
Slope or by the active Pipe Drainage Options (minimum 
cover, etc.). 
 
41. Select InRoads>Drainage>Lay Out. 
42. Toggle the “Add Connecting Pipes” checkbox ON. 
43. Click the “By Elevation” radio button. 
44. Hit the “Location” Target button 
45. Snap to the top end of the line labeled “Inlet 3”. 
46. Hit the Apply button.  
 
 Inlet3 should be placed. 
 
47. Hit the “Location” Target button 
48. Snap to the top end of the line labeled “Inlet 4”. 
49. Hit the Apply button.  Inlet4 and Pipe 2 should be 

placed.  
 
50. Continue Placing Inlets 5 and 6. 
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Section 5 Profiles 
Let’s take a look at the vertical information using the Profile command. 
The S&S Profile functionality is a superset of the InRoads Profile functionality. 
 
The S&S Profile form is identical to the 
InRoads Profile form with the addition of 
“Network” in the Source frame and the 
addition of the Network tab. 
 
Profiles is EXTREMELY customizable.  
Hours can be spending exploring all the 
options.  Typically, if there is something 
about the profile results that needs to be 
changed to meet your standards, there is a 
setting to change it. 
 
On the Main tab, the Important settings are:  
 The Source, which should be set to 
“Network” in order to cut a profile along 
the network; and 
 
The Symbology frames and the “Display” 
checkboxes which enable the Display of 
any of the surfaces.  
 
The Network tab contains the Network 
Structures frame, where the beginning and 
ending of the profile is chosen and the 
Symbology frame, where the display of 
various structures, HGL, EGL and Branch 
Lines can be toggled ON or OFF. 
 
Profiles can be run between any connected 
structures.  It does not matter if the flow is 
uphill, downhill, or even changes 
directions. 
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The Control tab contains two controls 
specific to S&S. 
 
The Drainage Network Reference allows 
the user to specify whether to  

• cut the Profile Along the Network 
or  

• cut the Profile Along the Active 
Alignment (e.g., a Roadway 
Centerline) and project the Drainage 
Structures to it. 

 
Manholes are displayed as prisms unless 
the “Display Manholes as Cones” checkbox 
is ON. 

 
 
 
51. Select InRoads>Evaluation>Profile>Create Profile…  
 
52. Select the Network tab. 
53. Select the Target button to the Right 

of the “From:” field. 
54. Select the Lower Left Inlet (IN3). 
55. Select the Target button to the Right 

of the “To:” field. 
56. Select the rightmost Inlet (IN6). 
57. Hit Apply. 
 
The form is minimized.   
 
58. At the “Identify Location” prompt, 

select a location for the origin of the 
profile. 

 
The profile is placed and the form returns. 
 
59. Close the form. 
  
 
Remember:  if you see something in the displayed profile that you would like to change or turn off, there is 
probably a setting for it.  Hit the Help button for help. 
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Section 6 Getting Flows into the System 
A network is not much good without flows.  Two things must be known about flows:   

HOW MUCH flow? And  
WHERE does the flow enter the system? 

“How much?” is modeled in S&S in two ways: “known quantity” flows, modeled as “Injected Flows,” and 
“area based flows”.  Injected flows are fixed quantities that never change throughout the number-crunching; 
Drainage “Area” and Sanitary “Zone” based flows can be adjusted (automatically by S&S) during 
computations.  For example, drainage flow can be adjusted due to travel time in the system and sanitary flow 
can be attenuated due to decreasing population-based peaking factors. 
 
Drainage “Areas” and Sanitary “Zones” can be calculated from MicroStation shapes or closed AutoCAD 
Polylines. 
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Given a Runoff 
Coefficient, intensity, and 
an area, a Flow can be 
computed and attached to a 
structure. 
 
S&S has functions to 
calculate a composite 
runoff coefficient from 
weighting a number of 
areas (hit the Compute 
button to the right of the 
“Runoff Coefficient” 
field). 
 
It also has functions to 
determine overland travel 
time (hit the Compute 
button to the right of the 
“Time of Concentration” 
field).  Given a time of 
concentration, S&S reads 
an IDF table to compute 
the Intensity.  
 

Area Flow 
Let’s Add some flow to our Network. 
The road in the dataset is normally crowned and flows to the right.  Let’s assume that the drainage areas for the 
curb inlet are bounded by the centerline, curb line, and the positions of the inlets. 
 
60. Place a MicroStation shape or AutoCAD 

P-line to represent the drainage area as 
shown to the right (Key in “place shape” 
in the MicroStation key-in field). 

 
 
61. Select “InRoads>Drainage>Flow>Compute Flow. 
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62. Select the Target button to the right of the Drainage Area field. 
63. Select the graphic shape placed in the previous step.   
 
The area for the shape is calculated and appears in the 
Area field (like all S&S default values, this can be 
overwritten). 
 
64. Since the entire area is pavement, key in a 

Runoff Coefficient of “0.90” 
65. Key in a Time of Concentration of “10” 

minutes.  An intensity is calculated from an 
Intensity-Duration-Frequency 

 
Once a “c”, an “i” and an “A” are defined, then a “Q” 
is calculated. 
 
Now we define WHERE the flow enters the system. 
 
 

 
 
66. Select the Target button to the right of the 

“Attach To:” field. 
67. Select the inlet the area drains to (the second 

inlet on the south side of the street).   
68. Hit Apply. 
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A database record is created for Astorm1 and the form 
prepares for the next area, by incrementing the “Area 
ID” and blanking out the “Drainage Area” and “Attach 
To:” fields. 

 
 
The shape’s symbology is changed to that defined for 
S&S Drainage Areas. 

 
 

Injected Flow 
69. Select InRoads>Drainage>Flow>Inject Flow. 
70. Select the Target button to the right of the 

“Attach To:” field. 
71. Select the “Upstream-most” (westernmost) 

inlet on the south side of the street (IN4).   
72. Key in “0.5” in the “Storm Flow” field. 
73. Hit Apply. 
74. At the “Identify Point” prompt, identify a point 

for the Flow label. 
75. Close the form. 
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Section 7 Doing the Number Crunching. 
  
76. Select InRoads>Drainage>Network>Design 
77. Select the “Tree Network Containing” radio 

button. 
78. Select the Target button next to the “Tree 

Network Containing” field.   
79. Select any of the structures in the southern 

network. 
80. Make sure that the “Generate HGL and EGL” 

checkbox is ON. 
81. Hit Apply. 
 
 

 
 
The network is designed, sequentially, structure-by-structure.  Some of the calculations performed include: 

• Establish connectivity based on Upstream and Downstream ID’s 
• Sum upstream injected flows 
• Sum upstream area flows 
• (Storm) Calculate flow travel time in pipes for time of concentration recalculations 
• (Storm) Recalculate rainfall intensity based times of concentration plus travel time. 
• Gutter flow depth and spread calculations 
• Inlet capture percentage from gutter flow characteristics 
• Adjust downstream gutter flow to include inlet bypass 
• Infiltration  
• Headloss at junctions 
• Hydraulic and Energy Grade line analysis 
• Pipe Sizing based on calculated flow and capacity. 
• Inlet Sizing based on sump/gutter capture capacity. 
• Junction resizing based on maximum pipe size. 

 
A Design log is generated, which echoes a good portion of the calculations and lists Warnings of exceeded 
design criteria and Errors.  This is the first and best source of information relating to how the network behaved 
during design. This log can be saved to files or sent to printers.   
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82. Close the Results form and the Network Design form. 
 
83. Select InRoads>Evaluation>Profile>Create Profile. 
84. Hit the Apply button (the settings have not changed since the last profile was created). 
85. At the “Identify Location” prompt, Identify a Location to place the lower left corner of the profile. 
Notice that the HGL is included, now that HGL information has been calculated during the Network Design. 
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Section 8 Saving the Drainage File. 
The Drainage file is saved in a way similar to any windows file, via the “Save” and “Save As… ”  The drainage 
with the label “s&sdata” was loaded at the beginning of the lab, as part of the “sns_biuc02.rwk” project file.   
 
86. To save the open file without changing the name, hit InRoads>File>Save>Drainage Data. 
 
To change the name, 

• hit InRoads>File>Save As... 
 

• Select “Drainage (*.sdb)” from the 
“Save as type:” list. 

 
• Key in a suitable filename.   

 
• Hit the Save button. 

 
 

Section 9 Exploring On Your Own…  
This concludes the formal part of the workshop.  The essentials “buttons” of Laying Out a Network, Attaching 
Flows, and Designing the Network has been touched upon.  Storm&Sanitary contains a great deal more 
functionality, most of which is found under the Drainage menu header.   
 
Additional Structures (Manholes, Channels, Culverts can be Laid Out) from the Lay Out form, using the same 
techniques as used for Inlets and Pipes. 
 
The “Access™  database” data architecture of the Drainage file allows wide-open access to all the copious 
information used by Storm&Sanitary.  Easy and versatile Annotation, Reporting, and Querying interfaces exist 
within S&S; more sophisticated Reports and Queries can be performed in Access.   
 
Important highlights include Structure Annotation, found at InRoads>Drainage>View>Annotate Structures, and 
Drainage Reports, found at InRoads>Tools>Drainage>Reports.  S&S also contains a suite of functions to 
quickly and intelligently modify network attributes, either individually or in bulk. 
 
Quickie:  Annotate Structures 
87. Select InRoads>Drainage>View>Annotate Structures.   
88. Hit Apply 
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The size of the resulting CAD text is based on the settings in the Symbology frame Multiplied by the Text Scale 
Factor which can be set in InRoads>Tools>Options>>Factors. 
 
This form provides the ability to annotate any of the structure or area attributes stored in the Drainage database.  
Position, Order, Precision, and Prefixes and Suffixes can be set via this form.   
 
 
 


