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Why I write InRoads Training Manuals: 
I love InRoads.  I want you to love InRoads.  InRoads deserves to be loved.  Poor training manuals 
obscure the inherent lovability of InRoads.  Eventually the power of InRoads will seduce them, but 
folks new to InRoads need to be coddled and nurtured until they get comfortable.  
 
Looking at the InRoads family of programs, the years of careful, broad-visioned dedication that went 
into designing and refining the software is obvious.  The architecture, interface, and capability is truly 
world class.  In looking at the learning process, the training manuals in particular, I did not see the 
same clarity of purpose and optimized implementation that I saw in the software.  I saw an approach 
that, frankly, was completely inappropriate for introducing a complex subject to new users. 
 
InRoads is a broad and extremely powerful engineering solution.  There are certain complexities that 
cannot be overcome because the engineering itself is complex.  The other complexities in the learning 
process must be eliminated (or at least postponed to an appropriate time). 
 

“I discovered that an expert in a field is not someone who knows a great deal about almost every aspect of that 
field.  Instead, an expert in a field is a person who understands the fundamentals of that field very, very well.” 

-- Dan Appleman, “Developing COM/ActiveX Components with Visual Basic 6” 
 
My vision is making learning InRoads as easy and enjoyable as possible. My focus is to simplify, 
prioritize, and emphasize the fundamentals to InRoads success.   
 

How to improve the InRoads learning process: 
Triage!  Triage!  Triage! 

 Keep it simple.  Increment.  Iterate. 
 Emphasize Great Technique. (Anticipate and Authenticate: every step). 
 
Triage:  we all remember watching M*A*S*H*.  An expert would examine the wounded and evaluate 
who needed immediate attention and who could wait.  A four-day InRoads class may seem like a long 
time, but unless good triage is performed, students walk out of the class distracted by trivia, without a 
clear understanding of how InRoads works and without the ability to hit the ground running. 
 
My overall goal is to have new users experience the power of InRoads without wallowing in the 
software “overhead” or trivia.  In a production environment, if the end-user is wallowing in the 
software overhead, he is wasting effort, time, and money and is probably not getting much design done.  
The software overhead should be managed by an InRoads Administrator in such a way that output is 
correct and standard, automatically (covered fully in Managing InRoads).   
 
Can one expect to have a very good understanding of how InRoads works, having touched every 
command and too many esoteric settings once each?  Or does it make more sense, for beginners, to 
ignore some rarely used commands to emphasize, focus on, and reinforce the critical commands and 
concepts which will ensure comfort and success? 
 
Here is how I apply Triage to introducing InRoads: 
 InRoads in its essence is simple.  Show the students the simplicity. 
 Emphasize and iterate the important concepts.  Incrementally add new concepts in small steps.  

Iteration is the mother of retention. 
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 Introduce less important concepts AFTER the more important concepts are mastered by the 
students. 

 
Important concepts to spend time on Less important topics 
Critical Concepts Less important Concepts 
InRoads Architecture All toggles for each command 
End Users can produce Standard Graphics and 
design in a managed environment 

Showing end users how to manage the 
environment 

Using Preferences as a way to change display 
without compromising standards 

Individually changing dozens of settings in every 
form 

that Tick Marks and all InRoads graphics are 
completely customizable. 

Repeated practice in changing Tick Marks 

 
Technique: What separates excellent users from less-excellent users?  Good habits and Great 
technique.  I will emphasize great technique and have you practice great technique.  Outside of the 
class, the best way to get good at InRoads is the same as the best way to be good at engineering: 
challenge yourself and get help from someone more experienced.  In this class, practicing good 
technique is emphasized.  The concepts and workflows in this book are presented in small increments, 
with Verification steps presented after every step, instead of at the end of a long sequence.   
 
The most important technique I can present to you in this book and in class is to Anticipate what will 
happen as a result of the command and to Authenticate that it has happened.  Never assume that a 
command works, verify that it has.  Eventually you will be able to tell immediately. 
 

Assumptions about the Audience 
My assumptions about the Audience are as follows: 

 They are familiar with Microsoft Windows and Windows Applications. 
 They are comfortable with viewing and erasing graphics in AutoCAD or MicroStation.  They 

should be comfortable attaching reference files and turning their display on or off. 
 They should be familiar with Civil Engineering concepts. 
 They are new to InRoads (or rusty or struggling). 

 

Assumptions about the User’s Work Environment 
The Ideal InRoads Environment 
Engineers, Designers and Drafters are at maximum productivity in a well-managed InRoads 
environment.  Engineers can focus on Engineering without paying any attention to the cumbersome 
trivia of symbology and cosmetics.  Drafters can quickly get sheet-ready graphics without excessive 
wallowing in details, while automatically conforming to Standards.  Designers can do whatever it is 
they do without worrying about software overhead.  The key to maximum productivity is to 
concentrate management of the software overhead to an InRoads-experienced individual or group (an 
IT guy who does no InRoads work is not appropriate), leaving everyone else free to focus on his or her 
job, wasting no time on software overhead. 
 
I am presenting this material as if the new user is a junior member of a well-managed InRoads team or 
department.  If the InRoads implementation is not well managed, the techniques presented here are a 
good goal to shoot for (for example, end users should be confident that pre-defined command 
Preferences will give them settings they need without having to change all the settings manually).   
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About the Style of my books 
I used to start my InRoads classes with a three-hour soliloquy presenting the theoretical foundations to 
InRoads.  I really, really like to make sure that the fundamentals are presented in an organized fashion 
(an expert understands the fundamentals very, very well), but a three hour lecture is not the best way to 
do it.  In fact, I have moved away from the lecture/lab dichotomy where I tell you why we push a 
button and 45 minutes later when we’re actually pushing it, we’ve forgotten why.  
 
Whereas previous versions of my manuals were designed as material for the classes I taught in person, 
this edition is designed for self-lead study.  As such I see little advantage in long narrative without 
clicking on buttons.  I’ve integrated user action wherever possible. 
 
This interweaving of explanation and users steps can be confusing.  I have tried to make the user steps 
“jump out of the text” as much as possible by using colored numbers, text and borders.  The user 
should be able to read background and concepts or simply “push buttons” as he sees fit. 
 
 
Document Conventions 

User Steps 
To segregate steps that the user must take from explanation or narrative, border lines precede and 
follow sequentially numbered instructions in the following style: 
 
1. User actions are segregated from narrative by this numbered, colored, bordered style.  If you want 
to know which buttons to push look between these green lines. 
 
This document format starts formally and very explicitly and gradually becomes more “vague.”  The 
purpose is to provide all the information in the beginning, and then later force the user to interact with 
the software rather than the documentation.   

Objects in the Software 
Objects in the Software, including controls and menus, are shown in the following style: Object 
 

Keyins  
Text the user must key in or information outside InRoads (such as file names) are shown in the 
following style: Keyins 

Commands 
Commands are referred to by their “menu path” conforming to the following format:  
 

Software>Menu_Header>Menu_Item>>”Leaf”   
 

“Software” is usually “InRoads” for the InRoads menu bar or “ustn” for the MicroStation menu bar.   
“>” indicates a submenu 
“>>” refers to a tab or other object on a form. 

 
For example, the “Factors” tab on the Options form is called out as: 

InRoads>Tools> >Options>>Factors. 
 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 x 

About “Exploring InRoads” 
There are core concepts that anyone who uses any of the InRoads products needs to know.  These are 
the “exploratory” commands that allow you to “see” what is in the InRoads data.  The book cover, 
while not pretty, is a good schematic of what the user will understand after completing this book. 
 
These “Display” commands are used to verify and evaluate InRoads data (this includes sophisticated 
commands such as Creating Cross Sections) and to create graphics for plans production.  They are 
“passive” in the sense that they do not alter the InRoads data model. 

Who this book is for: 
 People new to InRoads. 
 Engineers, Designers and Drafters who will be using InRoads regularly 
 Engineers, Designers and Drafters who will need to access and/or display information from 

InRoads 
 Reviewers and Managers who want to verify, evaluate or QC InRoads engineering data  

What this book covers: 
 The Data Model of InRoads 
 The InRoads Interface 
 Good technique and habits which will increase quality and quicken Mastery of InRoads 
 Good InRoads Management techniques 

 

What “Exploring InRoads” does not cover: 
 Building, Creating and Editing Tools (this is addressed in Part II: Building InRoads) 
 Advanced Topics (these are addressed in Part III: Mastering InRoads) 
 InRoads Implementation Management (this is addressed in Managing InRoads) 
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Learning More 
Exploring InRoads is designed as a stand-alone introduction to Building InRoads and Mastering Storm 
& Sanitary.  Building InRoads teaches the Active commands (those that Create and Edit the data 
model).  Visit http://civilxlr8.com for details and samples. 
 

Exploring InRoads (Part I of Mastering 
InRoads) 

Building InRoads (Part II of Mastering 
InRoads) 

  
Learn to Evaluate InRoads data models, 
create graphics and identify problems. 

Learn to Engineer InRoads models, create 
data and FIX problems. 

 
 
 
 
 
 
 
 
Feedback 
I welcome your feedback about this book, especially in the areas of style, formatting, data, preferences, 
errata, etc.  If you have any comments or questions please email me at info@civilxlr8.com 
 

http://civilxlr8.com/
mailto:info@civilxlr8.com




  Exploring InRoads 

Lab Setup 

The Data CD 

 
 
The Data CD may contain data for Exploring InRoads and other training materials.  The .EXE files are 
self-extracting datasets. 
 
2. Insert the Data CD. 
3. Double-click on “Exploring_InRoads.EXE” to invoke the Unzipping form. 
 
The default directory is 
“c:\train\Exploring_InRoads.”   
 
Another directory can be selected, but 
the book will refer to 
“c:\train\Exploring_InRoads.”   
 
4. Click “Finish” to extract the files. 

 
The “Exploring_InRoads” folder contains all the data, unzipped, including any extra or AutoCAD data, 

© 2004-7 Civil XLR8    April 13, 2010  xiii
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Cells: 
The datasets make extensive use of cells (for AutoCAD, blocks).  While these are not necessary, they 
highlight the power of the software.  The cell libraries (*.cel) should be included in the MicroStation 
configuration cell library list.   
 
The cell libraries can be  
  copied into the MicroStation default cell folder (preferred) 
  the MicroStation Configuration variable, MS_CELLLIST, can be modified to include the library, or 
  the MicroStation Cell Library directory list, MS_CELL, can be modified to include the data 
directory.to include the appropriate directory. 
 
Example: 
5. Select MicroStation>Workspace>Configuration 
 
6. Hit the Select button to add 
the 
“c:\train\xlr8_preferences” 
directory to the MS_CELL list. 
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7. Select 
“c:\train\xlr8_pref
erences.” 
8. Click the Add 
button. 
9. Click the Done 
button. 
 
10. Hit the OK button 
on the Configuration 
form. 
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Chapter 1: InRoads: an Overview 

The Essence of InRoads 
In its broadest sense InRoads creates a 3D electronic model of an engineering job and provides the means to 
create construction documents from the 3D model.   
 
A civil engineering project can consist of a wide variety of objects with engineering significance, including 
such things as centerlines, asphalt courses, shoulders, valley gutters, signs, ditches, underground utilities and 
rights of way, to name just a few.  InRoads manages this intelligence using some of the straightforward and 
intuitive ways found in common GIS systems.  The InRoads DTM (Digital Terrain Model) can geospatially 
model all this information with an accuracy exceeding that required for construction.   
 
The InRoads Digital Terrain Model is supplemented by the InRoads Geometry Project which contains the 
exact mathematical representation of circular, parabolic and transitional curves which cannot be maintained 
within the current DTM data structure.  The formulaically diverse Geometry Project can appropriately model 
geometric standards used throughout the world and is a fundamental component in building design models 
and graphics. 
 
While it is not impossible to develop an DTM which can store curved geometry definitions, managing two 
file types is comparatively easy and is not a high price to pay for the benefits of having separate file types 
(speed and simplicity of concept). 
 
Currently the Geometry Project and Digital Terrain Model provide the complete physical model of an 
engineering project.  All graphics and supporting data for construction documents can be derived from these 
files.   
 
All the information that we in the civil engineering community use to bid and build projects is “secondary 
information” derived from the InRoads data model.  Pushing an InRoads Display or Report button generates 
information from the data model.   
 
The resulting information is not necessarily updated if the model is changed.  Often an Update button needs 
to be pushed to update the graphics.  When managing InRoads projects or engineering departments using 
InRoads, it is important to understand that the electronic model the engineers design and the information on 
the paper documents may need to be updated. 
 

Primary Data Model Files: 

The Geometry Project (.alg).   
This file contains all Geometry information, including COGO points, horizontal and vertical alignments, and 
associated event points.  This file is essentially self-contained, encapsulating all geometry related 
information.  From the Geometry Project all the familiar and required Geometric information can be derived. 

The Digital Terrain Model. (.dtm).  
 The DTM can contain and geospatially represent everything that currently exists and/or will be created as 
part of an engineering project (subject to a definable maximum error).  Curves, including Spirals, for 
example, are represented by 3D linestrings (or polylines) of connected straight chords.  While the DTM can 
output physical location of the elements to be built within an acceptable error, the DTM data format cannot 
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support, for example, reports that provide the “geometric sense” that is required for civil engineering 
mathematics (curve radii, superelevation rates and transition information, etc.). 
 
Proposed roads can represent complex and sophisticated engineering requirements and are often defined by a 
potentially long series of criteria.  In creating Proposed Corridors or “Roadways” InRoads mirrors the typical 
engineering specification: a library of typical sections and a “table” listing which typical sections are 
dropped where along an alignment.  While the InRoads “Corridors” provide repeatability and documentation 
as to the major steps used to create a proposed corridor, they are support files.  The end result of the process 
and the source for all earthwork drawings and calculations, regardless of the complexity of the engineering, 
can be a single complete DTM. 
 

Settings/Support Files 
 A Preference file controls the details of the cosmetics and a variety of engineering settings.   
 InRoads uses a number of user-specified and user-definable files for settings for specific engineering 

tasks (such as superelevation rate tables).  The Preference file stores which specific files are used. 
 
Engineering Support Files 
These files are used in the definition of the proposed roadway corridor and creation of the proposed DTM.  
Together these files provide the ability to archive, repeat and edit corridor model creation. 

 A “Typical Section Library” is used to define typical road sections, or “templates,” side slope or 
catchpoint definitions 

 A “Roadway Design” file is the “recipe” for creating the finished surfaces, including specifications 
for template drops and transitions, independent controls, and superelevation. 

  

CAD Graphics 
While CAD graphics are the “be all, end all” of production sheets, they are virtually irrelevant to the InRoads 
model.  While InRoads can import information from CAD graphics and does a wonderful job creating and 
managing CAD Graphics, InRoads does not need or use graphics for any of its calculations.  If you lose or 
erase graphics, InRoads does not care.  The information InRoads needs is stored in its own files.   
 
Some important concepts about CAD graphics in InRoads: 

 every graphic is customizable.  If you don’t like it you can change it 
 the graphics are normal CAD graphics, to the CAD program they behave like every other graphic 
 if you delete the InRoads graphics, InRoads is okay with that, InRoads has everything it needs in its 

own files (.alg, .dtm., etc.) 
 all graphics that are displayed as part of a single “button push” are displayed in MicroStation as a 

single graphic group (which permits easy deleting or other manipulation) 

Debugging 
Sometimes, InRoads and the graphics get out of synch.  Guess who is right:  InRoads.  InRoads always wins.  
When debugging in InRoads, it is important to realize that the InRoads graphics are a snapshot of the 
InRoads model when the graphics were created.  That model may have changed since the graphics were 
created (many InRoads commands delete old bad graphics automatically).   

Primary InRoads Debugging Steps 
Prior to Trouble: 
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Anticipate and Authenticate at every step:   
 Know why you are using a command,  
 Know what your expected results will be 
 Verify that what you thought should happen actually did happen 
 Save your work. 

 
The sooner you know you’re in trouble the sooner you can get out.  InRoads commands have 
innumerable toggles; one set incorrectly can dramatically affect your results.  No excuse for losing data:  
saving your work can take only as long as a “Ctrl-S” or “Ctrl-G”. 
 

Once something seems amiss: 
Don’t trust the graphics! 

1. open a blank CAD file or Save the file to a new like “debug” or “deleteme”. 
2. Delete all the graphics. 
3. Use an appropriate display tool to create new, “in-synch” graphics.  These can be trusted because 

they came straight from the InRoads files. 
4. If things look awry, use a review or evaluation tool to examine the questionable object in more detail. 
5. Go to the source.  How was the questionable object built?  What steps or commands were used to 

reach the current, questionable state. 
 
These are not just steps for beginners.  These are the quickest and most direct steps even for someone with 
years of experience. 
 

Secrets to InRoads Success 
 Exploit experienced colleagues (or other sources for help).  A production environment with access to 

experts is perhaps the surest way to gain mastery (this is true for both InRoads in particular and 
Engineering in general. 

 Have an experienced InRoads user manage InRoads Preferences (and other overhead) and its 
distribution.  This allows users to focus on their work and eliminates many people imperfectly 
duplicating overhead work. 

 Use good, explicit naming conventions.  Take advantage of InRoads’ capability to self-document. 
 Expect and Look for feedback (Anticipate!). 
 Verify each step (did InRoads do what you think it did?) (Authenticate!). 

 
 
.  
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Chapter 2: Getting Started in InRoads 

 

Chapter Goals: 
 Launch InRoads 
 Become familiar with the InRoads Explorer 
 Understand the Organization of InRoads 
 Understand the major files InRoads uses 
 Understand that graphics are byproducts of the InRoads model 
 Understand how to help InRoads manage project data (InRoads>File>Project Defaults) 

Note: this book, this lab and dataset are for “passive” commands.  There are also no graphics that cannot be 
derived from the InRoads data files.  The labs are not dependent on any of the data from previous labs.  
There are no harsh consequences (or at least there should not be).  Feel free to experiment and “play.”  Be 
bold, be fearless. 
 

Starting InRoads 
 
1. From the Windows Start Menu, select “Programs” or “All Programs” (depending on your Windows 
version). 
2. Select “Bentley”. 
3. Select “InRoads Group XM”. 
4. Select “InRoads” or “InRoads Suite” (depending on your license). 
(in the future these steps will be notate like this: Select Start>All Programs>Bentley>InRoads Group 
XM>InRoads Suite.) 
 
Note: older versions of InRoads are located elsewhere as Bentley changes the “formal name” of InRoads and 
the program shortcut from time to time.  For example, v8.3 was found at “Start>Programs>Bentley Civil 
Engineering>InRoads” 
 
If InRoads has not been run on the machine and multiple 
CAD platforms are installed, the “Select CAD Platform” box 
is invoked.   
 
Select your preferred CAD Platform and then hit OK. 
 
You can switch CAD platforms by selecting “Start>All 
Programs>Bentley>InRoads Group XM>Select CAD 
Platform.” 

 
The selected CAD platform launches (this book will use MicroStation XM). 
 
Depending on a setting in MicroStation you will see either or the Windows style MicroStation Manager box 
or the “old” MicroStation Manager 
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Or 
 

 
 
(the setting is the “Use Windows File Open Dialogs” in MicroStation>Tools>Preferences>>Look and Feel). 
 
5. In the MicroStation Manager dialog box, select “c:\train\Exploring_InRoads\working.dgn”. 
6. Hit OK. 
 
After MicroStation initializes, an InRoads Splashscreen should come up followed by the InRoads Explorer. 
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(Note: from within MicroStation, InRoads can be launched from Tools>MDL Applications, select 
civust*.ma in the InRoads bin directory.   From within AutoCAD, InRoads can be launched from 
Tools>Load Applications, select civAcad*.arx in the InRoads bin directory.  Function keys or other 
shortcuts can simplify initiating InRoads from within the respective CAD programs). 

The InRoads Explorer 
Primary Interface 
The InRoads Explorer is the primary interface for accessing the InRoads suite commands, as well as an 
immediate feedback “window” into active files, settings, and results. 
 

 
Menus 
The InRoads Explorer contains the menus from which all the InRoads commands are accessed.  In this 
manual, we will refer to the Menu Bar in the InRoads Explorer as the InRoads Menu Bar.  References to 
commands located here will be preceded by InRoads> to distinguish them from commands accessible from 
the CAD package menu bar. 
 
Toolbars 
InRoads Toolbars are identical to Windows toolbars: they can be “docked” in the Explorer, “undocked” to 
float free in the application, resized and customized. 
 
Let us turn on an extremely important toolbar, the Lock toolbar. 
 
7. Right-Click on the InRoads Menu bar. 
8. Select Locks. 
 
Locks can also 
be selected via 
InRoads>Tools   
>Locks>Toolbars 

 
Locks settings affect how InRoads behaves.  Having the Locks toolbar visible make debugging easier. 
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Explorer Panes 
The InRoads Explorer is very similar to the Windows Explorer.  The InRoads Explorer starting with Version 
8.2 differs from the Windows Explorer in one significant way: the left or “Workspace Pane” is not the 
hierarchical “treeview” that can show all file types at once.  This was removed due to performance issues.  
Instead the left pane has a “Workspace Bar” at the bottom with tabs to view the various file types.   
 
The Panes are resizeable.  If all the tabs cannot fit within the width of the Workspace Pane, arrow buttons 
allow the user to scroll through the options.  
 

 
 
If many InRoads products are loaded this can be a bit cumbersome.  A shortcut is to right-click on a tab, 
which then shows all the file types. 
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Right Mouse Button 
The ability of the right-mouse button to invoke context-sensitive menus is one of the biggest ease-of-use 
improvements since the development of the mouse itself.  It provides the user immediate access to an 
object’s most often used commands.  The InRoads Explorer makes extensive use of the right mouse button.  
When in doubt: Right-Mouse! 
 
Feedback 
InRoads is not a great communicator.  It will sometimes let you do very dumb things without saying much 
and then at the least convenient time make a big deal about a “trivial” distant bygone.  InRoads 
communication is often inconsistent, terse, vague, subtle when it should be aggressive and aggressive when 
it should be subtle.  Sometimes there is no communication whatsoever.  In order to avoid unnecessary 
heartache it is very important to understand how InRoads communicates. 
 
First, InRoads does not yell.  In fact, InRoads is completely silent.  In a few years, perhaps the program will 
allow Audio files to be part of the command feedback “Dave.  I’m afraid I can’t let you do that”, but until 
then InRoads feedback is entirely visual. 

Message Field 
The primary way InRoads communicates to the user is through the Message Field which is located in the 
lower left corner of the InRoads Explorer.   
 

 
 
InRoads also uses the CAD message fields to communicate with the user.   
 
InRoads will prompt the user for an action and provide confirmation after completion of a command.  Many 
commands have a number of consecutive steps where InRoads behaves differently depending on the user’s 
actions.  Even after years of using InRoads, reading the prompts is very important.  As a beginner it is 
critical. 

Message Boxes 
Occasionally, InRoads will force you to acknowledge a problem with a dialog box.  If there is a Help button, 
additional data is provided about the problem. 
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The Message Box is one of the few times InRoads IS a good communicator.  At almost all other times the 
feedback is subtle and easy to miss if you are not looking for the feedback. 

Executing InRoads Commands 
The first step in Executing an InRoads command is not “pushing a button.”  The first step is having a clear 
idea of the engineering step to be taken.  If you are not clear on the engineering InRoads will only help you 
make a mistake electronically. 
 
Initiating a Command. 
InRoads commands are initiated from the InRoads Menu or from toolbars.  Most invoke a form.  Others 
solicit information from the user via prompts in the InRoads and/or CAD message fields. 
 
Anticipating Feedback 
Most, if not all, InRoads commands require information from the user.  Expect and Look or feedback. 
 
Authenticate Successful Completion 
Whether you are new to InRoads or a seasoned expert, verification of the successful completion is great 
technique.  It uncovers errors immediately rather than later in the workflow when the cause can be very 
vague.   If you are properly Anticipating what the command should do, then you should have an idea of what 
the results should be.  Often Verifying that the command work requires using an additional step, such as 
displaying contours.  This extra step, with practice, can take little time and save lots.   

Prompts 
Most commands will echo a message stating the success or failure of a command.   

Additional Feedback 
Most InRoads commands result in some graphic output.  It is good technique to have the CAD view set up so 
that the graphic result is immediately visible upon completion of the command.   
 
The results of many actions in InRoads are reflected in the InRoads Explorer.  When working with a 
particular file type in InRoads, it is helpful to have the “Workspace Pane” set the appropriate file type.  For 
example, when you are doing geometry work, select the Geometry tab to see geometry information in the 
InRoads Explorer Workspace Pane and Results Pane. 
 
Using good technique allows InRoads to alert the user more actively with graphics and Explorer feedback in 
addition to the subtle “message prompt.”   
 
In every case there are InRoads commands which allow confirmation of every engineering action.  Until you 
are very familiar with a command, it is an excellent idea to spend a little time verifying that “what you 
thought should happen actually did.” 
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InRoads Files 
InRoads works with a number of different file types.  Design work can easily require seven or eight files to 
be opened in InRoads at any given time. 
 
Information File Type  Necessity Comment 
Graphics dgn(MicroStation) dwg 

(AutoCAD) 
Required InRoads needs a graphics file to work in; it 

does not matter what the file contains 
Geometry  alg Primary model Precise geometric mathematics 
Surface dtm Primary model Engineering and Surface Model 
Templates itl support Used to define proposed corridors 
Corridors ird support Used to define proposed corridors 
Preference xin Required, support All symbology & many engineering settings 
 
InRoads must start in a CAD file.  The other types are visible from the InRoads Explorer. 
 
InRoads at StartUp 
The CAD platform and CAD file is decided prior to InRoads getting loaded.  Upon loading, InRoads loads 
Settings files only.  No “data” files are loaded. 
 

Settings Files 
Upon loading, InRoads loads the Preference file, which controls just about everything in InRoads.   
If InRoads is running, it is using a Preference file.  Which files is InRoads reading right now? 
 
9. Right-Click on the Tab Bar in the Workspace Pane.   
10. Select Preferences. 
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Notice the Preference file.  It may or may not match that shown below. 
 

 
 
The Preference file is an important file.  It is very important to ensure that InRoads loads the proper 
Preference file.  “Project Defaults” is the mechanism to do this and will be covered later in the next section. 

Data Files 
InRoads loads no data files automatically.  It does have blank data structures with the names “Default” ready 
to use.  These “Default” data structures should not be used.  Use InRoads>File>Open to open existing files 
or InRoads>File>New to create new ones. 
 
11. Select each of the Workspace tabs (Surface, Geometry, etc.) to verify which files are loaded.  
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Setting up Projects in InRoads 
Typically the first step on the computer when starting a project is to create a project folder to manage all the 
project files.  “Project Defaults” is where you tell InRoads what files and folders are associated with a 
Project.  In addition to setting default “project” folders, a Project definition also defines which Preference 
file to automatically load at startup. 
 
12. Select InRoads>File>Project 
Defaults…  
 
If no Project Defaults are set up, the form 
looks like this. 
 

 
Virtually all InRoads forms have a Help button, which provides button-level help for objects on a form. 
 
13. Click on the Help button to see how the Help for this form looks. 
14. Browse through the help for this form. 
15. Close the Help form. 
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16. In the Project Defaults form, click on the “New…” button. 
17. Key in “Exploring_InRoads” in the Name field.  
18. Click OK. 

 
We now have a Project set up, with 
nothing in it. 
 
The top frame, Default Preferences, is for 
files that are automatically loaded 
depending on what products are loaded.   
 
A Preferences (*.xin) file, for example, is 
loaded every time any of the InRoads 
products is launched. 
 
If a preference file is not specified, 
InRoads loads one, most likely the one in 
the InRoads product install folder, which 
is a generic default and probably not very 
appropriate.  It is, therefore, extremely 
important to manage the preference file 
well. 
 
The Browse button is “shared” by all the 
text fields. 
 
 
 
 
 
19. Place the cursor in the “Preferences 
(*.xin):” keyin field.  
20. Click on the Browse button. 
 
 
21. Navigate to the training 
preferences or “settings” folder (by 
default 
“c:\train\xlr8_preferences”) 
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22. Select the “civil_xlr8.xin” 
file. 
23. Hit the Open button. 

 
The Preference file is added to the 
Preference file text field. 
 
24. Hit Apply to store this definition. 
 
InRoads stores this information for 
“Exploring InRoads” in the Windows 
registry for future use. 
 
Note to Administrators: since the information is 
stored in the registry, it is machine- and –user 
specific.  The Export and Import buttons allow 
some “shareability” in Project definitions. 
 
If we were lazy, we could close the form 
and start working.  Like most attempts to 
be lazy, however, if we were to close 
now, we’d wind up having to work much 
more in the long run.  Let’s do it right. 
 
We will be using Drafting Notes later, so 
let us manage them now: 
 
 
 
 
25. Place the cursor in the “Drafting 
Notes (*.dft):” keyin field.  
26. Click on the Browse button. 
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The Open box should open to the 
correct folder (if not, navigate to 
c:\train\xlr8_preferences) 
 
 
 
 
 
 
27. Select the “notes_xlr8.dft” 
file. 
28. Hit the Open button. 
 
 
 

 
 
The “Default Preferences” frame is now 
populated for our needs. 
 

The bottom frame is for “Default 
Directory Paths.”  We do not define files 
here, but the folders they are located in.   
 
The end result of populating the fields in 
this frame is that when we Open or Save 
a file the forms open in correct folder. 
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Let’s start populating the Default Directories. 
 
29. Place the cursor in the “Project 
Default Directory:” keyin field. 
30. Click on the Browse button. 
31. Navigate to the training folder: 
“c:\train\”. 
32. Select Exploring InRoads 
 
 
 

Notice the “file” and “file type” 
fields are not visible, as we are not 
defining files.   
 
33. Hit the Open button. 
 
 
In theory, defining the “Project Default 
Directory” field and leaving the 
remaining blank should cause all File 
Open or File Save As boxes to default to 
this directory.  It does not, however.  To 
ensure that all File boxes default to the 
right place we must define all the fields. 
 
 
 
34. Set the default directories to  
“c:\train\Exploring_InRoads” for the 
remaining file types (except the last two). 
See the previous five steps for reference. 
 
Copying and Pasting is one very efficient 
way to fill these fields out. 
 
35. When all the fields are filled, click 
Apply. 
 
The “Exploring InRoads” project is now 
defined in InRoads. 
 
36. Click Close to dismiss the form. 
 
 

ghts Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 
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Now, unless the Project Defaults Configuration is changed, the correct project Preference file should 
automatically be loaded and all default paths should be correct. 
 
 
 
 
 
 
 

Chapter Review 
We should now: 
 Be able to Start InRoads 
 Be familiar with the InRoads Explorer 
 Be able to set up InRoads Project Defaults to help manage project files. 
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Chapter 3: InRoads Help Sources 

 

Chapter Goals: 
 Understand where to get help from within InRoads 
 Be aware that there is a very good Tutorial called “Working with InRoads” delivered with InRoads. 
  Understand how to get it. 
 Be aware of other sources of InRoads help. 

Help from the Menu 
InRoads Help can be reached from the InRoads>Help toolbar 
 

 
 
 
Selecting InRoads>Help>Contents will invoke the 
standard Windows Help form with the familiar 
Contents, Index and Find functionalities. 
 
Reference Information is a command-by-command 
detailed description of “button-level” functionality.  
It is organized in the menu hierarchy.   
 
Using the Software tends to lean towards an echo of 
which buttons are pressed in which order.  It offers 
little explanation. 
 
Supplemental Information contains topics that are 
new or do not fit into either of the previous help 
hierarchies.   
 
 

 
 
InRoads>Help>Search for Help on… brings up the Help form with the Find tab active. 
InRoads>Help>Technical Support is a somewhat generic list of support resources provided by Bentley, 
including phone numbers, email addresses and web links. 
InRoads>Help>About Bentley Civil will tell you the version number, including which Service Pack is loaded. 
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The Help Button 
The first and most immediate place to go for help is the Help button which is on most of the forms (also 
known as dialog boxes) in InRoads.  The Help button takes the user directly to explanations of the command 
and objects on the active tab of the active form.   
 
For example, hitting the Help button on the Advanced tab of the View Contours command invokes Help for 
that form. 
 

 
This Help is excellent for “object-specific” explanations.   
 
The “How to” button is supposed to provide a higher “workflow” level of explanation.  In the past it has not 
been robustly supported, but Bentley has expressed an increased commitment to making this a good source 
of help.  Give it a try. 

Select Services 
In all likelihood, you or your company is paying for software maintenance, which includes free upgrades and 
a variety of support services.  While there are Email and Phone support for non-Select “subscribers,” the 
corresponding services under the “Select” support umbrella is much more responsive.  You will need your 
Select ID in order to use these services.   
Phone Support 
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Civil Knowledge Base 
The Civil Knowledge base is the keyword-searchable public-access area where a variety of InRoads-specific 
information is stored, include responses to common questions and “white papers” on special topics.  It is a 
good place to try to find information, but the interface is not inviting or particularly user friendly. 
 
Bentley.InRoads 
The Bentley.InRoads discussion group is a great resource for asking questions to the Bentley personnel who 
monitor it and the worldwide InRoads community at large.  The web address is 
http://discussion.bentley.com.  You may have to log in to bentley.com, drill down through “Support” and 
“Discussion Group.” 
 
 
 
 
 
 
 
 

Chapter Summary 
We should now have a good idea on where to get help on InRoads 

 
 
 

http://discussion.bentley.com/
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Chapter 4: Exploring Geometry 

 

Chapter Goals 
Given an unknown Geometry file, be able to “figure out what the heck is going on with it” 
 Understand the Organization of the InRoads Geometry Project 
 Be able to load a Geometry Project (.alg) file 
 Be able to use the InRoads Explorer to “Explore” an unknown Geometry Project. 
  Be able to View and Review Horizontal Alignments 
 Become familiar with the Horizontal Annotation command 
 Become familiar with the View Stationing command 
 Understand the value of trying “pre-defined” command Preferences 
 Become familiar with the Tracking command 

Geometry Organization 
The InRoads hierarchical organization of geometry is not dissimilar to the old pre-electronic organization of 
geometry.  In the manual world, a filing cabinet or a flat file drawer might be set aside for all geometry 
information for a project.  The InRoads equivalent is the Geometry Project. 
 
The Geometry Project holds all the Geometry information and is the “unit” that gets saved and loaded as a 
file (an .alg (alignment) file).   
 
Every Geometry Project has a COGO Buffer for coordinate geometry points unassociated with horizontal 
alignments. 
 
A Geometry Project can contain zero or more Horizontal Alignments which can contain linear elements, 
circular and transitional curves and horizontal event points. 
 
Like manual methods, zero or more Vertical Alignments can be associated with a Horizontal Alignment.   
 

 
This hierarchy is reflected in the InRoads Explorer though Event Points are not shown. 
 
Note to users of prior versions of InRoads users:  Superelevation is now defined in the Roadway Designer. 
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The InRoads Explorer below shows the MesaPark Geometry Project (the InRoads Explorer behaves just like 
the Windows Explorer). 

 
 
Geometry Projects are designated by the icon .  The Default Geometry Project always exists and has a 
COGO Buffer, a horizontal alignment named Default, a Vertical Alignment named Default, and a 
superelevation definition named Default.  These elements are all blank.  While they can be used, it is 
recommended that the user work with Geometry other than the Default Geometry Project and its children. 
 

Active Objects 
InRoads is in many cases designed to work with multiple objects of a given type.  For example, many 
Geometry Projects can be opened at a given time and each may contain many Horizontal and Vertical 
Alignments.  To specify which of many like objects to work with, InRoads recognizes and works with only a 
single instance of an object type as “Active.”  For example, in the screenshot above, there are two Geometry 

Projects loaded; the Red border around the MesaPark Geometry Project icon  designates it as being the 
Active Geometry Project.   
 
The MesaPark Geometry Project, like all Geometry Projects, has one COGO Buffer, identified by its icon  
 
The MesaPark Geometry Project contains a number of Horizontal Alignments, designated by the horizontal 
alignment icon .  The one with the red border is the Active Horizontal Alignment.  Expanding the 
“ha_canyon_rd” horizontal alignment (done by double-clicking on “ha_canyon_rd” or single-clicking the 
plus sign in front of it).shows its vertical alignments  and superelevation definitions (if from an earlier 
version Geometry Project). 
 

Exploring the Geometry 
There are many ways to get information from the Geometry Project, including Viewing, Annotating, and 
Generating Reports.  We will start with information available from the InRoads Explorer and with the 
commands available when clicking the Right Mouse button on the various Geometry objects in the InRoads 
Explorer.   
 

Loading the Geometry Project 
Since we will be working with Geometry, let us give ourselves the opportunity for maximum feedback by 
setting the InRoads Explorer to “Geometry”: 
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1. Click on the Geometry tab of the Workspace Pane. 
 
2. Right-click on the 
“Geometry Projects” object. 
3. Select “Open” 
 
This invokes the standard 
windows “File Open” dialog 
box with the “File Type” set to 
“Geometry Projects (*.alg)” 

 
 
 
This form can be invoked from the 
menu, InRoads>File>Open, but the 
File Type may not be set to 
Geometry Projects (*.alg).  If not, 
select it from the “Files of Type:” 
listbox. 
 
The “Files of type:” listbox is used 
to filter which of the several file 
types are displayed in the file list.  
If you do not see the file you are 
looking for, make sure that the File 
Type is set appropriately. 
 

 
4. Select (single-click) 
“mesapark_v84.alg” from the file 
list. 
5. Hit Open. 
 
The Open form remains open so that the user may load additional Geometry Projects or files of other Types, 
but notice the feedback InRoads provides:   
 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 4-4 

 
 

The Message field reads “File’C:\…\Exploring_InRoads\existing_MesaPark.alg’ Opened.”  Notice the 
MesaPark Geometry Project is shown in the Explorer and that it is the Active Geometry Project. 
The MicroStation message field also echoes the same message: 
 

 
 
6. Hit Cancel to close the form 
 
7. Expand the MesaPark 
Geometry Project by hitting the 
Plus Sign  to the right of 
MesaPark object. 
 
 
8. Single-click the MesaPark 
object.   
 
This will show MesaPark’s 
children in the Results pane. 
 
The red bordered icon for “ha_canyon_rd” indicates that it is the Active Horizontal Alignment.  Yours may 
vary. 
 
Notice the Headings in the Result pane.  They are standard Windows ListView Headers and can sort (by 
clicking) and can be ordered differently (by dragging).  Note that the headings visible in the above 
screenshot probably different from the first several in your InRoads Explorer.  Integrity is a valuable QC tool 
in InRoads (while still a liability in politics) and the Style controls the default symbology display of an 
element and should provide useful qualification of data (and is often used in place of qualification in 
politics).  Feel free to explore and reorder your InRoads Headings. 
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9. Expand everything that is 
expandable. 
 

We can see all the COGO 
Points and Horizontal and 
Vertical Alignments in the 
Workspace pane (as well as 
information in the Results 
pane). 
 
 

Right mouse button 
The right mouse button has been used since Windows 95 to invoke an object’s Context Menu, a list of the 
most common commands typically used with an object.  The InRoads Explorer takes good advantage of this 
functionality.   

Setting Active Alignments.  
The easiest way to make an alignment or superelevation Active is to right-click on it, and select the “Set 
Active” menu item.  Note: setting an object as Active automatically sets its parent (and grandparent, et al.) as 
Active.   
 
10. Right-Click on the “canyon_proposed” 
Veritical Alignment. 
11. Select “Set Active”. 
 
 
 
Notice that “ha_canyon_rd”, the parent of “canyon_proposed”, was automatically set as the Active 
Horizontal Alignment. 

Displaying Alignments 

12. For clarity, delete/erase all graphics using standard CAD commands. 
 
13. Right-Click on 
“ha_Balcony_Road”.  
14. Select “View” from the 
most popular Horizontal 
Alignment commands. 

April 13, 2010  4-5
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15. Right-Click on 
“ha_Balcony_Road” again. 
16. This time select “Fit” 
which is right below the 
“View” on the context menu. 
 
 

 
 

Balcony Road is displayed.  Note that ha_Balcony_Road is now the active alignment. 
 
Troubleshooting 
If Balcony Road is not visible, there are a number of possibilities as to why. 
 
If you are using MicroStation/J or earlier (upgrade right away!, it is possible that the Geometry does not fall 
within the geospatial limitations of the design file.  A design file covering the surface limits would be 
required. 
 
Notice that the Active Alignment was switched to the object just acted upon.  Many times throughout 
InRoads when an object is selected for an action InRoads makes it Active and then performs the Action. 
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17. Right-Click on “ha_canyon_rd” 
18. Select “View” 
19. “Fit” or “Zoom All” the CAD window. 
 
20. Using the Right Mouse, View all of the 
Horizontal Alignments. 
21. “Fit” or “Zoom All” the CAD window. 
 
 
 
While very easy for small projects, this method of 
exploring the Geometry Project may be too time 



  Exploring Geometry 

© 2004-7 Civil XLR8    April 13, 2010  4-7

consuming for projects with dozens of horizontal 
alignments.  The View Horizontal Annotation 
command is used to “customize” the alignment 
display and to Annotate the horizontal geometry.  It 
will be addressed later in this chapter. 
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Reviewing Alignments 
 
22. Right-click on the 
“ha_canyon_rd” horizontal 
alignment. 
23. Click on Review... 

 
 
 
The Review Horizontal Alignment form is invoked.  This is a versatile and useful form.  This form can also 
be invoked via the menu: InRoads>Geometry>Review Horizontal… 
 

 
 
This form is an extension of the standard InRoads Results form.  From any InRoads Results form, the text 
can be Saved As a text file, Appended to a text file, Displayed as text in the CAD file and sent directly to a 
Printer. 
 
The Review Horizontal Alignment command has a number of additional controls that make it very useful.  
 
Mode 
First is the Mode radio buttons.  By default the Mode is Alignment which displays information about all the 
elements in the alignment.  This mode also displays messages as to the Integrity (colinearity) between 
elements.   
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The Element mode shows highlights the element graphic and displays information about the element 
sequentially through the alignment.  The First/Previous/Next/Last/Select buttons are enabled to allow 
stepping through the alignment.  This is very useful for determining the direction of an alignment as well as 
in debugging (the defined order of elements may not be geospatially sequential (see the Horizontal Element 
Tools). 
 
Selecting the Alignments for Review 
Any Horizontal Alignment in any loaded Geometry Project can be selected from the “Horizontal Alignment” 
and “Geometry Project: “ listboxes, respectively.  This works well if the user knows the names of 
Alignments. 
 

If the user does not know the name of the Alignment, he can use the Target button  to the right of the 
Horizontal Alignment listbox to pick the Alignment graphically in the CAD file. 
 
24. Right-Click on “ha_canyon_rd” 
25. Select “Review” 
 
26. Select 
“Element” for 
Mode. 
27. Use the Next 
button to “walk 
through” the 
alignment. 
 

 
 
 
28. Use the Target button to review another alignment. 
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View Horizontal Geometry Commands 
Geometric graphics and the data stored as part of the Geometry Project are not the same thing. 
 
InRoads maintains a double-precision “database” of the geographic information.  Graphics can be derived 
from that “database.” Deleting graphics does nothing to the InRoads data.  InRoads can make use of 
information from graphics, but all required data is stored in the .alg file.  This is different paradigm than 
CADD packages where the graphics are an integral part of the data model. 
 
View and Annotate Geometry commands can be accessed via InRoads>Geometry>View Geometry   
 

 
 
or from the View Geometry toolbar 

 
which is accessible via InRoads>Tools>Customize>>Toolbars>View Geometry.  The command order for the 
menu and the toolbar is identical. 
 
Display Active Horizontal Alignment immediately draws the active horizontal alignment in the InRoads 
geometry file.  

Horizontal Annotation 
View Horizontal Annotation Form 
The primary command to Display and Annotate Horizontal Alignments is the View Horizontal Alignment 
command.  It controls display of horizontal alignments or COGO points; both the objects and their 
annotation.   
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The Essentials 
The Main tab 
 
The Main tab contains controls for displaying 
Horizontal Alignments and Points.   
 
Selecting the Geometry to Annotate 
The most critical control on the form are the Include 
controls, which are used to select which Alignments 
or “free” Points to Display or Annotate.  Wildcards, 
such as “*” and “?” are acceptable and can be used 
to select multiple elements.   
 

The locator buttons  to the right of the Include 
keyins can be used to graphically select the 
alignment or point closest to the cursor (subject to 
the Feature/Graphic lock mode).   
 
The Selected listboxes will list the alignments or 
points that have been selected for display. 
 
The Display frame has toggles to designate what 
elements and alignment points to display.   
 
The Annotate frame contains toggles to turn on and 
off specific types of annotation. 
 

 
 
Geometry Selection Filter 
When the cursor is in either Include: textbox, the Filter button is enabled.   Hitting it invokes the Geometry 
Selection Filter form which allows the user to pick and choose from all available Alignments or Points. 
 
The top right quarter of the 
form is a series of filters to 
eliminate unwanted objects.   
Points or Alignments can 
be filtered by Name, 
Description, and Style as 
well as by relation to a 
fence. 
 
Wildcards are useful and 
necessary. 
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The bottom half of the form is the complementary set of objects passing the filter: those that will not be 
displayed and those that will (Available and Selected, respectively).  Standard Window selection techniques 
apply (shift+ and ctrl+).  The buttons in the middle are used to move selected items from one set to the other. 
 
 
29. Select InRoads.>Geometry>View Geometry> 
Horizontal Annotation. 
30. Key in “*” in the Horizontal Alignment Include 
field 
31. Hit the Apply button on the Horizontal 
Annotation form. 
32. Fit or Zoom all the CAD window. 
 
Each Alignment is displayed, with no Annotation, 
according to its Geometry Style (predefined 
symbology definitions) which is a property of each 
alignment. 
 
 
 

 
Preferences 
The Annotate Horizontal Alignment form illustrates a common theme in InRoads: lots of options.  Getting 
all the toggles correct can be a daunting and confusing task.  Success in InRoads is best achieved by 
leveraging the experience of more advanced users.  This is best managed through a mechanism know as 
Preferences. 
 
Preferences allow the user to save and reuse all the settings, under all the tabs, on a form.  Most InRoads 
forms have a Preference button.   
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33. Hit the Preferences button on the Annotate form. 
 
The Preferences form is invoked.  It lists the predefined 
preferences for the form.  The highlighted Preference is the 
Active one.  Currently, default-xl is the Active Preference 
for this form. 
 
34. Select default-no_annotate-xl 
35. Hit the Load button. 
 
This loads predefined settings under all the tabs on the 
Horizontal Annotation form, including under the Tabling and 
Styles tabs.   
 
36. Close the Preferences form. 
37. Hit the Apply button on the Horizontal Annotation form. 
 
The result should be identical to the previous results  Why? 
 
The default-xl and default-no_annotate-xl Preferences are the same.  The InRoads Administrator set up 
all the toggles and options to meet some criteria.  He then saved a Preference with the somewhat descriptive 
name default-no_annotate-xl.  At some point he decided that this was a good default preference and 
saved it as default-xl.   
 
38. Delete all the CAD Graphics using appropriate CAD commands. 
 
Let’s try a different preference. 
 
39. Hit the Preferences button on the Annotate form. 
 
The Preference form is invoked.  
40. Select default_annotate-xl 
41. Hit the Load button. 
42. Close the Preferences form. 
 
This loads all the settings (under all the Horizontal Annotation 
form’s tabs) that were saved in the preference named default 
_annotate-xl. 

 
 
 
 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 4-14 

Notice the Annotate Points and Elements toggles 
are checked. 
 
43. In the Annotate textbox, key in “*future” 
44. Hit the Apply button on the Horizontal 
Annotation form. 
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The ha_canyon_rd_future alignment is displayed and annotated. 
 
45.  Zoom in on and examine the various annotation 
 
Note: the annotation can be displayed in larger text by adjusting the Text Scale Factor 
(in InRoads>Tools>Options>>Factors) and re-displaying the alignment. 

Annotation Detail 

  
 

Styles 
Symbology of graphics associated with an alignment is controlled by Geometry Styles. 
 
By default an Alignment is displayed according to 
the Style assigned to it (as shown in the screenshot 
to the right). 

 
 
The “Apply Style” frame allows displaying the 
selected alignments with a selectable “Active” 
Style. 
Caution: the “Overwrite” toggle will change the 
selected Alignments defined Style (you do not want 
to do this accidently). 

ril 13, 2010  
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Symbology of graphics associated with an 
alignment is controlled by Geometry Styles as 
specified under the Styles tab. 
 
The class default settings using two Styles for 
representing points:  “geom_alg_Point” which uses 
a circle and “geom_alg_Point_Triangles” which 
uses a triangle. 
 
Point symbology can adhere to the settings on here 
or its parent alignment’s Style by toggling 
“Alignment Style Overrides Point’s Style.” 
 
Ancillary Elements’ symbology can be designated 
via listboxes in the Element frame. 
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Geometry Styles 
reference a Named 
Symbology, which 
allow defining Points, 
Lines/Curves, and Text 
in a wide variety of 
ways.   

Changing the 
symbology is outside 
the scope of this 
chapter.  See Geometry 
Styles and Named 
Symbology Manager in 
the Tools Menu for 
further information. 
 
Setting up Geometry Styles or other Preferences can be time consuming.  In any organization with more than 
one InRoads user, it is best to designate someone to coordinate and manage setting up the “details and 
cosmetics” of InRoads to avoid duplicated effort. 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 4-18 

Displaying Stationing 
Alignment Stations can be displayed via the Stationing command. 
46. Select InRoads>Geometry>View 
Geometry>Stationing 
 
The Stationing command is like most InRoads 
commands: completely customizable and, therefore, 
containing a large number of controls under multiple 
tabs.     
 
Again, it is best to try pre-defined Preferences before 
spending a great deal of time tweaking the various 
toggles. 
 
The Main Tab contains the pick list to choose which 
Horizontal Alignment to Station.   
 
47. Make sure that the Horizontal Alignment is set to 
“ha_canyon_rd_future”. 
 
Other highlights include the Interval keyin and the 
Symbology frame which allows defining whether to 
(check box) and how to (symbology settings) display 
the various stationing elements.   
 
 
48. Click the Regular Stations tab. 
 
The Regular Station tab holds the controls for the major 
and minor stationing elements that occur at the Interval 
specified on the Main form.  Settings for the 
orientation, direction, justification, format, precision 
and other elements of the station callouts and tick 
marks are found here.   
 
The Minors/Major ratio is set here. 
 
Note the Minor Station format here is sss+[ss.ss].  
The labels for minor stations will show only the 
information within the brackets. 
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Controls in the additional tabs are similar in format to those in Regular Stations allowing customization for 
labels and leaders for : 
 Cardinal Stations  points defining the alignment such as POB, PC, PI, PT, POE, etc. 
 PI’s defines how the PI labels appear 
 Station Equations  user defined points where the station is redefined 
 Radius + A  labels radius for curves and “infinity” for tangents 
 Transition Radii (new with v8.4) labels transitional curve radii 
 Event Points  user defined points of interest such as monuments or minimum clearance points, etc. 
An example of the results of the stationing command is shown below: 
 
 
49. Hit Apply. 
50. Zoom in tight enough to see the 
stationing text. 
 
 
Note: All the text and leader lengths 
are multiplied by the Global Text 
Scale Factor (found under 
InRoads>Tools>Options>>Factors).  
If all the text is too large or too 
small, changing the Global Text 
Scale Factor and re-Displaying the 
Stationing is the easiest and fastest 
way to change the size). 
 
The display is multi-colored to 
show which graphics belong to 
which Station element type 
(Regular, Cardinal, PI’s, etc.).  The 
size is also multiplied for print 
clarity by a factor of 6.0 over that in 
the class data. 
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Example:  Displaying Stationing According to Agency Standards 
Let’s assume we want to display the stationing according to something resembling an agency standard 
symbology.  Typically an agency requires all the Stationing to be displayed in the same color and level. 
 
How do we display this according to the agency standards? 
 
The Long, Hard, Tedious Way: 
We can double-click on an element type in the 
symbology frame and change its definition. 
 
We would have to do this for each of the sixteen 
different element types.  Even if we were to use good 
technique by selecting a Named Symbology for each, it 
takes some time AND: 

 It might already have been defined for us!!! 
 
 
 
 

 
The Easy, Consistent, and Good QC Way: 
Look for pre-defined settings; i.e., preferences. 
 
Our InRoads Administrator has set up a predefined definition (a Named Symbology) for the agency proposed 
stationing standard. 
 
51. Hit the Preferences button. 
52. Select all_proposed_bylevel-xl 
53. Hit Load 
54. Close the form. 
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This loads the “Guaranteed Standard” settings created 
by the InRoads Administrator (if the settings are not 
correct, it is HIS fault, NOT yours!). 
 
Notice in the Symbology frame all the element types are 
using the same Named Symbology 
(“align_prop_stationing”) and the color column shows 
ByLevel rather than a color (it is truncated to “BYL”).. 
 
 
55. Hit Apply. 

 
The new “Standard” Stationing is 
displayed. 
 
 
Note: feel free to explorer other 
Preferences. 
 
Note to Administrators:  the proper way to 
have all the elements use BYLEVEL as 
color would be to change the change the 
color definition in the 
align_prop_stat*Named Symbologies. 
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Tracking 
The Tracking command provides useful Geometry feedback and labeling functionality. 
 
56. Select InRoads>Tools>Tracking>Tracking 
 
The Tracking command provides feedback tied to the 
cursor in the CAD drawing (including precision location 
via snapping).  Information is derived from the Active 
Horizontal Alignment or the Active Surface, if either 
exists.  If not the information in the form or label is blank 
 
After hitting the “Activate” button the Tracking form lists a 
number of different Properties about the position of the 
cursor.  
 
A data button in the drawing (clicking the left mouse 
button) leaves a text label at that point. 
 
57. Hit the Activate button to 
activate the tracking command. 
58. Drag the cursor around the 
CAD view.  
59. Place a data button <D> 
somewhere to see the Tracking 
annotation.   
 
A label will be created based on 
the properties at the data point 
location.  The symbology of the 
label is set under the Symbology 
button. 
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Clicking the Settings button on the 
Tracking form invokes its 
Symbology form where the details of 
the tracking information can be 
defined. 

 
 
 
 
 

 

Chapter Summary 
We should now be able to: 
Given an unknown Geometry file, “figure out what the heck is going on with it” 
 Understand the Organization of the InRoads Geometry Project 
 Load a Geometry Project (.alg) file 
 Use the InRoads Explorer to “Explore” an unknown Geometry Project. 
  View and Review Horizontal Alignments 
 Use the Horizontal Annotation command 
 Use the View Stationing command 
 Understand the value of trying “pre-defined” command Preferences 
 Use the Tracking command 
Do preliminary debugging when using Geometry Create/Edit commands 
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Chapter 5: Exploring Surfaces 

 

Chapter Goals: 
Given an unknown DTM, be able to “figure out what the heck is going on with it” 
 Understand how the new version 8 DTM is an Engineering Model 
 Be able to load a Surface (.dtm) file 
 Be able to use the InRoads Explorer to “Explore” an unknown Surface 
 Be able to load and use the View Surface toolbar 
 Understand what a Feature is 
 Know how to find information about a feature (the Feature Properties command). 
 Become familiar with the View Surface commands 

Overview: An Engineering Model 
The data structure of the old (pre-Version 8) Digital Terrain Model is sufficient to create an accurate 
mathematical model of an existing or proposed ground surface.  The “intelligence” of the old DTM consists 
merely of the X, Y, Z coordinates of points and whether a point is connected to another point as part of a 
linear feature.  This is the extent of the intelligence of the old data structure.  The mathematical model of the 
ground surface consists only of a network of triangles created from these points.  From this triangulated 
network, contours can be derived or profiles and sections cut.  Beyond this mesh of triangles, the old DTM 
contains no other information.   
 
We as Civil Engineers may need to know a lot more about the existing ground or proposed ground than the 
old DTM is capable of conveying.  We may need to know that a particular survey shot represents the throat 
of a grate inlet or a series of shots represents a Face of Curb.  The new DTM data model allows us to store 
this and other intelligence with every object in the DTM.   
 
        Pre-v8:  Triangles + “Dumb” Breaklines Only    V8: Triangles + Intelligent Features 
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Additionally, we now have the option of modeling objects that are not at-grade.  This allows us to represent 
above- or below-ground utilities, for example.   
 
The new DTM model incorporates the same “old” triangle model for defining the “ground surface”.  Both 
models use five Point Types which control how the triangle network is created.   
 
Every object in the new DTM is known as a Feature.  The Feature has a number of new properties including 
a Name, an optional Description, and Feature Style (what type of object is it?), as well as the Feature [Point] 
Type. 
 

 
 
The Exclude from Triangulation toggle allows Features to be excluded from the “ground surface.”  This 
property allows modeling above- or below-grade utilities.  
 

Loading the Surface 
Since we will be working with a Surface, let us give ourselves the opportunity for maximum feedback by 
setting the InRoads Explorer to “Surfaces”: 
 
1. Click on the Surfaces tab of the Workspace Pane. 
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2. Right-click on the “Surfaces” 
object. 
3. Select “Open” 
 
This invokes the standard 
windows “File Open” dialog box 
with the “File Type set to 
“Surfaces (*.dtm)” 

 
This form can be invoked from the 
menu, InRoads>File>Open, but the 
File Type may not be set to 
Surfaces.  If not, select it from the 
“Files of Type:” listbox. 
 
4. Select (single-click) 
“existing_MesaPark.dtm” from 
the Exploring_InRoads project 
directory. 
5. Hit Open. 
 

 
Notice the feedback InRoads provides:   
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The Message field reads “File’C:\…\Exploring_InRoads\existing_MesaPark.dtm’ Opened.”  Notice the 
existing_MesaPark Surface is shown in the Explorer and that it is the Active Surface. 
The MicroStation message field also echoes the same message: 
 

 
 
The Open form remains open so that the user may load additional Surfaces or files of other Types. 
 
6. Hit Cancel to close the form 
 
Notice that the “internal label” of the surface matches the file name.  While the software places no 
restrictions and requires no relationship between the label and the file name, it is a good idea to leave no 
opportunity for confusion as to what the surface is and what its filename is. 
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Exploring the Surface 
Let’s take a look at what surface information or functionality is available in the InRoads Explorer: 
 
Active Surface 
InRoads works with or reads information from the Active Surface.  The Active Surface has the red border 
around the icon .  To set a surface active, it is easiest to right-click on the surface and select Set Active.  A 
surface can also be set as Active via InRoads>Surface>Active Surface. 
 
Surface Information 
 
7. Expand the 
existing_MesaPark 
Surface. 
 

 
 
Of particular importance when evaluating “what is going on” is the number of various types of Features and 
the number of triangles.  Zero Triangles indicates the traditional “terrain” model has not been calculated.  No 
contours will be able to be displayed, nor will the surface show up in profile or cross section, since these are 
by product of the triangle model. 
 
8. In the Results Pane, 
scroll to the right to see 
the remaining columns. 
 
 

Column order can be 
changed by dragging the 
column headers. 
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9. Right-Click on the 
existing_MesaPark surface in 
theWorkspace Pane.. 
 
The tasks available from the 
context manual are used quite 
often. 
Triangulate creates the triangle 
terrain model. 
 
Properties allow changing 
Display and other surface 
properties. 
 
10. Click on Properties 
 
(Surface Properties is also available through InRoads>Surface>Surface Properties…) 
 
The Surface Properties form is 
invoked. 
 
The Data Range and Data Totals 
frames contain information similar 
to that which is available in the 
InRoads Explorer. 
 
The other Property fields are used 
quite often to change the (internal) 
Name and Description of the 
surface and to adjust triangulation, 
display and volume-calculation 
properties. 
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The controls under the Advanced 
tab control the display of the 
surface graphics in Profile and 
Cross Section. 

 
 

Viewing DTM information 
The primary way of evaluating surfaces is from graphics.  A wide variety of surface graphics can be 
displayed via the View Surface commands, which can be found under the InRoads>Surface>View Surface 
menu. 
 
Like all graphics displayed graphics by InRoads, theses surface graphics can be copied, deleted/erased and 
by the CAD software like any other graphics created by the CAD software. 
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View Surface Commands 
All the Surface view commands can be found in the InRoads>Surfaces>View Surface menu. 
 
 

 
 
 
The View Surface Toolbar 
 
When doing a lot of Surface display it saves 
time to invoke the View Surface toolbar. 
The View Surface toolbar roughly parallels 
the View Surface menu, item-by-item in 
sequence, and can be invoked from the 
Customize form 
(InRoads>Tools>Customize).  
 

 
 
The toolbar may come up docked in the InRoads Explorer or it may be free floating as shown below.  It can 
be stretched into a variety of rectangular shapes. 
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Stretched vertically and 
superimposed on the menu, the 
“roughly” parallel layout is 
obvious: 
 

 
 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 5-10 

Customizing the View Surface toolbar 
 
The menu commands are preceded by the command’s icon if one 
exists.  A technique to aid recognition of the sometimes-cryptic icons 
is to Customize the toolbar command to include the Name of the 
command as well as the icon.  This can be done by having the 
Customize form invoked and right-mousing on the command.  Select 
“Image and Text” 
 
Note: the right-mouse options shown to the right only are available if 
the Customize form (InRoads>Tools>Customize) is open. 
 
 
 
 

 
 
 
One technique to become familiar with toolbars is to turn on “image 
and text” for most commands, then gradually turn of the text for the 
commands you become familiar with.  
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Viewing Features 
Viewing Feature Graphics 
Most of the “traditional” DTM commands are “triangle-based”.  If the number of Triangles is zero, the 
triangle-derived objects cannot be displayed.  Features, on the other hand, are the fundamental building 
blocks of the DTM.  Features are always displayable and are, therefore, a great starting point in exploring the 
DTM.   
 
Let us view the features of the MesaPark surface. 
 
11. Select 
InRoads>Surface>View 
Surface>Features… 

 
 
The View Features form contains the following 
important objects: 
 
Object: Purpose: 
Surface: Selects the surface from which to 

choose features to display 
Features: This lists the features in the Surface 

by name.  Highlighted Features are 
displayed and can be selected via the 
typical Windows selection techniques 
(Ctrl and Shift keys) and right-
clicking in the Features listview. 
Columns are sortable. 

Target 
Button:  

 

Allows selecting the feature 
geographically from the CAD 
window. 
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12. Make sure All the features are selected (right-click and click Select All if necessary). 
13. Hit the Apply button. 
14. Close the form. 
 
Troubleshooting 
The Features are displayed as shown to 
the right.   
 
Note: the symbology may differ 
depending on the Preference file used. 
 
If the features are not visible, there are a 
number of possibilities as to why. 
 
The surface may lie outside the limits of 
the current view (use the CAD “Fit” or 
“Zoom All” command.   
 
If the features are still not visible, make 
sure that the InRoads Write Lock is On.  
If it is not, turn it On 
(InRoads>Tools>Locks>Write), then 
repeat the View Features steps. 

 
If you are using MicroStation/J or earlier (upgrade right away!), it is possible that the surface does not fall 
within the geospatial limitations of the design file.  A design file that can fit the surface in it would be 
required. 
 
Viewing Feature Properties 
So far, we have seen the geospatial layout of the surface features and that there is some speciation in the data 
based on the differing symbology of the graphics.  The DTM may contain tremendous amounts of 
“intelligence” that isn’t obvious graphically.  To “explore” the data contained in the features, use the Feature 
Properties… command 
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15. Select InRoads>Surface>Feature>Feature Properties… 
 
 

 
 

Triangulation Properties 
All Properties with any significance to the traditional terrain model are contained in the Triangulation frame. 
 
The Exclude from Triangulation toggle, when ON, enables feature to exist in the DTM without being part of 
the terrain triangle network. 
 
If the “Exclude from Triangulation” toggle is OFF 
the feature is triangulated into the terrain model 
according to the Feature  
Type defined for the feature.  Each Type is behaves 
differently mathematically. 

 

We will use the Target button  to graphically select a number of features.  
 
16.  In the Feature Properties form make sure the Surface is set to existing_MesaPark. 

17. Select the Target button  
 
The form minimizes to “get out of the way” during selection.  Notice the prompt in the CAD message area.  
It echoes the Name of the Feature nearest the CAD data point.  Accepting the Feature will bring the form 
back with the feature properties displayed.  If the “tentative” Feature is rejected, InRoads searches for the 
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next nearest Feature.  Its name is echoed in the CAD message area.  InRoads will continue searching through 
the DTM until every feature is selected.   
 
18. Accept and Review a number of Features. 
 
Exercises: 
19. Determine which road is Canyon Road.  Which is Arroyo Road?   
20. Do any of the roads have adjacent sidewalks? 
 
Feature properties can also be labeled in the CAD drawing using InRoads>Surface>View Surface>Annotate 
Features command (feel free to play with this if you have time). 
 
ToolTips 
 
If you are running later 
versions of MicroStation, the 
Select Tool will display the 
InRoads information of any 
graphic the cursor identifies.  
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Viewing the “Traditional” DTM Functions 
The “Traditional” Terrain Model consists of points and lines which make up a model of the existing or 
proposed ground surfaces.  The ground surface model consists of a network of triangular planes, from which 
information can be shown such as Contours, Slope Vectors, and spot elevations anywhere in the the network 
of triangles.  The ground surface can be also displayed in Profile and Cross-Section views.   
 
Note: If Style Lock is ON clicking the following commands will generate graphics automatically without 
showing the respective Command boxes.  Style Lock should be OFF for these labs. 
 
View Perimeter 
A good starting point in Exploring the surface graphically is to view the boundary or Perimeter of the 
Surface: 
 
21. Select the InRoads>Surface>View Surface>Perimeter 
command 
22. Make sure “existing_MesaPark” is the surface selected in 
the Surface listbox. 
23. Hit Apply. 
 

 
 
 
The Perimeter of MesaPark should 
display similarly to the screenshot 
to the right.   
 
If the perimeter does not display, 
verify that the surface has been 
triangulated (use the InRoads 
Explorer see how many triangles 
are contained in the surface). 

 
Viewing Surface Triangles 
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The fundamental mathematical unit of the InRoads terrain model is a triangle between three (non-collinear) 
points in space.  All display information, including contours, spot elevations and slope vectors, is derived 
from the triangles.  Triangulation is the process by which triangles are created from random points and linear 
features.  Triangulation among random points is a “best guess” algorithm and linear features might be 
triangulated in a way that does not match the “real world” surface.  Since everything is derived from the 
triangles, viewing the triangles is a critical step in the quality control of the surface.  Each triangle vertex 
corresponds to an XYZ or NEE point in the source data.  Each triangle side represents a linear relationship 
between two points.  This linear relationship may deviate from what exists in the real world and might need 
to be corrected. 
 
24. Select InRoads>Surface>View Surface>Triangles. 
25. Hit Apply. 
 

 
The triangles are displayed 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
InRoads will, by default, place 
3D graphics, at their proper 
elevation.  If the contour labels 
are not present or hard too find, 
snapping on any contour will 
echo its elevation to the CAD 
prompt field.  Note: InRoads 
works fine in 2D files. 

 
 
Viewing Contours 
While the triangles are the model from which every thing else is derived, they are not of tremendous use to 
Civil Engineers not doing surface quality control.  To get an idea of “layout of the land,” display the 
contours. 
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26. Select InRoads>Surface>View Surface>Contours. 
 
The View Contour form has two tabs the Main tab and an Advanced (or “Details”) tab.   

The View Contours form, Main tab The View Contours form, Labels tab 
 
This is a typical layout for the InRoads forms: a Main tab with the critical or primary tools and options; 
secondary functions segregated by tab.   
 
27. Hit Apply. 
 
This generates the familiar 
contour map of the surface, 
which we should be able to 
interpret.  
 
By default the contours are 
drawn in 3D at the proper 
elevation,.  If labels are not 
visible, a contour’s elevation 
can be derived by snapping 
to it. 
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and the number of Minor contours per Major (this is a roundabout 
ay of specifying the Minor Interval).   

 

r apart and vice-versa (in an unusual twist, the algorithm is actually explained in the Help for this 
ommand). 

 would be extremely difficult to mess anything up using this command so: 

 
 
While all the controls on this form have a definitive function, the object of primary interest on the Main tab 
is the Interval between [minor] contours 
w
 
Labels often need tweaking to provide a “correct look.”  An appropriate “Spacing” of labels, for example, is
dependent on the amount of terrain relief and the density of contours.  A higher Spacing number makes the 
labels farthe
c
 
It
 
28. Change a bunch of Settings and Hit Apply. 
29. Repeat. 
30. Use the Help button for specific information about a particular control, if needed. 

1. Repeat. 3
 
As you can see, even in a relatively simple command the permutations of options add up quickly. 
 
The Value of Preference Sets 
Very often Contours of the existing ground are displayed on different levels and with different symbology 
than proposed grade Contours.  How do we change the settings?  If your reaction is to start messing wit
the various controls, your reaction is premature:

h all 
  you first should see if the InRoads Administrator has 

lready set up appropriate preferences for you. a
 
 
32. In the View Contours form, select the Preferences… button 

 

 

t up a number of Preferences, including 
n Existing preference. 

The administrator has se
a
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A “Special Purpose” to Surface Preferences 
Existing surface’s contours should always be displayed according to Existing Contour standards, right?  
InRoads should know that an Existing Surface should always display Existing Contours and Proposed 
Surfaces should always display Proposed Contours, right?  InRoads does.  Here’s how: 
 
One Property of a Surface is its Preference (as shown here in the 
Surface Properties box).  If the Style Lock is ON, pressing a View 
Surface command searches the command’s Preferences for one with 
the same name as that defined in the active surface’s Preference 
property.  If it finds it, it displays the surface graphics according to 
the Preference’s settings (if the Preference does not exist, it displays 
the graphics according to a default preference). 

In this way, users shouldn’t have to continually worry about 
managing the display of surface graphics. 
 

Other View Surface Commands 
 
The remaining View Surface commands provide a wide variety of commands which allow 3D visualization 
of the surface.  They behave in roughly the same way as the View Perimeter, View Triangles and View 
Contour commands.  Feel free to experiment.  None of the View Surface commands alter the surface data or 
definition.  Any of the graphics can be erased using the CAD erase/delete commands. 
 
 
 
 

 

Section Review 
We should now be able to: 
Given an unknown DTM, “figure out what the heck is going on with it” 
 Understand how the new version 8 DTM is an Engineering Model 
 load a Surface (.dtm) file 
 Use the InRoads Explorer to “Explore” an unknown Surface 
 load and use the View Surface toolbar 
 Understand what a Feature is 
 find information about a feature (the Feature Properties command). 
 use the View Surface commands 
perform preliminary debugging on Surface Create and Edit commands 
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Chapter 6: Introducing Profiles and Vertical Alignments 

Section Goals: 
 Become familiar with creating Profiles. 
 Be able to display Vertical Alignments. 
 Be able to review Vertical Alignments 
 Be able to display Vertical Alignment Annotation. 

Profiles and the InRoads Engineering Model 
Civil Engineering is a 3D Endeavour.  Paper is a 2D medium.  Representing Civil Engineering on paper 
typically consists of three 2D views:  Plan, Profile and Cross Section.  In the old primitive days of Civil 
Engineering, say, up to the year 2000 and the introduction of InRoads v8, the three views of the same 
engineering objects were completely independent in both their creation and their upkeep.   
 
One of the primary purposes in developing the Intelligent DTM was to eliminate the need for manual and 
repetitive drafting in the engineering process.  Engineering content is often revised, tweaked, or wholly 
abandoned.  “Final” drafting was a largely manual process, sometime involving the manual placement of 
cells (or blocks).  Any changes to the engineering required reworking the drafting which was time-
consuming and prone to error and omission.   
 
The end result of the InRoads Intelligent DTM is that the software can manage all your engineering drafting.  
Its tools build and edit a 3D model from which InRoads produces and updates graphics in Plan, Profile, and 
Cross Section, including cells.  The plan “View” commands and Create and Update commands for Profile 
and Cross Section all read from the Intelligent DTM.  The workflow for updating the engineering “content” 
in the profile after a change to the design is simply to use the Update Profile command. 

Creating Profiles 
Profiles are important for a number of reasons 

 They are a major component of construction documents 
 They can provide the graphic component of such tools as Curve Diagrams and Superelevation 

Diagrams 
 They are a tool for Exploring the Surface 
 They are the graphic windows for viewing Vertical Alignments. 

 
This chapter focuses on the later two reasons: exploring surfaces and vertical alignments. 
 
To clarify terms: 
 Vertical Alignments are mathematical representations of vertical civil engineering geometry.  The are 
“owned” by Horizontal Alignments in an InRoads Geometry Project. 

Profiles (or Profile Windows) are the graphic window which represents a view perpendicular to a 
plan view along some horizontal path, which may or may not be a horizontal alignment.  Profiles are 
“containers” that can include and represent any number of terrain surfaces, DTM Features (engineering 
objects such as ditches, fire hydrants, etc.), vertical alignments, and other engineering information. 
 
The following data files are required to create Profiles: 
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That’s right: NO data is required.  Profiles can be cut without either Geometry or Surface data loaded in 
InRoads.  They are of limited use, though, as they are simply empty grids. 
 
Given a surface and the View Surface tools we are already familiar with (View Contours, for example) we 
can get an idea of “what is going on” with the surface.  Profile views of a surface provide a linear view of the 
relative slope along a path.  If that path is along a horizontal alignment this can have precise engineering 
meaning.  Once we have a Profile along a Horizontal Alignment we can display Vertical Alignments and 
Annotation.  We can also project features to the Profile and show where features cross the Profile. 
 
Profiles are a good example of InRoads commands that produce graphics:  

 every graphic is customizable.  If you don’t like it you can change it 
 the graphics are normal CAD graphics, to the CAD program they behave like any other graphic 
 if you delete the InRoads graphics, InRoads is okay with that, InRoads has everything it needs in its 

own files (.alg, .dtm., etc.) 
 all graphics that are displayed as part of a single Apply are displayed in MicroStation as a single 

graphic group (which permits easy deleting or other manipulation) 
 
Note: All the commands in this lab produce graphics but do not alter the data in the InRoads files.  It is safe 
to “be creative” or “mess up.”  The InRoads data will be fine. Experiment and be bold! 
 
1. Make sure the existing_MesaPark Surface and MesaPark Geometry Project are loaded (How do we do 
that?). 
2. Select InRoads>Evaluation>Profiles>Create Profiles. 
 
The Create Profile form 
is invoked.  The form is 
a monster.  The result of 
the form is a great deal 
of graphics and every 
bit can be customized in 
every way.   
 
The organization of the 
form differs from the 
forms we’ve seen so far: 
instead of tabs across 
the top we have a “tree” 
down the right side. 
Bentley refers to 
individual units as 
“leafs.” 
 
 
 
3. Hit Apply, just to see what happens. 
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What happens is the Profile form minimizes (freeing up screenspace) and you 
get the vague and overused prompt in the CAD message field “>Identify 
Location”.   
 
What this means is “Place a Data Point <D> where you want the lower left 
corner of the profile to be.” 
 
4. Place a Data Point <D> where you want the lower left corner of the profile to be. 
 
The profile is then displayed. 

 
 
5. Zoom to see the whole profile.  Notice the Profile grid fits the Terrain in it (automatically).   
 
The lower left corner detail shows the surface symbology and the axis and label details.  Everything you see 
is customizable. 
 

 
 

“Content” and “Container” 
The engineering model, related data (including underground or overhead utilities), and annotation can be 
described as the profile Content.  The grid, axes, labels, titles, etc. are collectively the Container to display 
the Content. 
 
As mentioned earlier InRoads has tools to display and update the engineering Content in the profiles 
throughout the design lifecycle.  The “Container,” on the other hand is static; there is no “Update” for the 
labels, grid spacing, vertical exaggeration, etc.  If you don’t like how the container looks, you have to re-
Create Profiles. 
 
Working with Profiles 
In this section we will explore some of the more important controls in View Profile command.  Profiles (and 
Cross-Sections) have literally hundreds of customizable options.  The Help button will explain every option 
on each “leaf” in the form and is a good resource. 
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Deviating from Standards 
Experienced users everywhere run into conflicts between “deliverable standards” and “designing standards.”  
Often what looks good on an 11”x17” plotted sheet is not optimally clear when designing on-screen.  Text 
Size and Vertical Exaggeration of profiles and cross sections are examples.  The profile we just displayed 
with default settings may conform to some deliverable standards, but in a long design life-cycle we might 
want to tweak some settings to make things clearer. 
 
While the hands-on step-by-step will not have us create a new, personalized Profile Preference, an 
experienced user would do just that when he deviates from standards and wants to re-use the “mutation.” 
 
Profile Display Controls 
The most important things in the form are:   
 

Concept Location (leaf) 
which Surfaces are you displaying? General 
what is the Source of the horizontal path to cut along? Source 

 
The General “Leaf” 
The graphics resulting from this command are known in InRoads as a “Profile Set.”  InRoads manages 
multiple Profile Sets by assigning names to each one.  The names must be unique. 
 
InRoads provides a 
default “Set Name” 
which is typically the 
name of the active 
horizontal (plus a 
numeric suffix).  The 
Set Name can be 
overwritten by the user. 
 
Profiles can be drawn 
from Left to Right or 
from Right to Left. 
 
Vertical Exaggeration is 
set here. 

 
To change the symbology of a surface in profile, select the surface and then hit the Properties button.  This 
invokes the Surface Properties form, where you can change the surface’s Symbology for Profile. 
 
In the General “leaf” the Symbology frame lists all the Surfaces loaded in InRoads.  The checkbox preceding 
the Surface name is used to turn that particular surface Display ON or Off. 
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The Source “Leaf” 
 
Profiles can be cut along 
a: Horizontal 
Alignment, Graphics, 
along a number of 
Points, and points 
specified in a Text file.   
 
If a Storm&Sanitary 
Drainage file is loaded, 
a Profile can be cut 
along a Drainage 
Network. 
 

 
 

Horizontal Alignments vs. “Spontaneous” Alignments 
While InRoads can cut Profiles along non-Horizontal Alignments, a horizontal alignment is needed in order 
to use some of the Annotation and Update commands  The “Alignment” box next to the non-Horizontal 
Alignment options allow the user to define a Horizontal Alignment for the profile “on-the-fly” so that all 
Profile-related commands can be used.  Note:  use a clear naming convention so that your “spontaneous” 
alignments are not confused with your “deliberate” alignments. 
 
The Include “leaf” 
The Include “leaf” 
provides the ability to 
add data types to the 
profile display. 
 
A good default is to 
leave all these options 
off. 
 
Crossing and Projected 
Features are more easily 
managed via the Update 
Profile command. 
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The Network leaf 
The Network leaf allows 
inclusion and 
Symbology definition of 
Storm&Sanitary data. 

 
 
The Offsets “leaf” is seldom used and is legacy form days prior to the Intelligent DTM. 
 
The Control Limits 
“leaf” is used to specific 
explicit Elevation Limits 
and to create Profiles 
shorter than the entire 
alignment by specifying 
Beginning and End 
Stations. 

The Window Clearance 
is used to add some grid 
“buffer” above and 
below the highest and 
lowest surface 
elevations in the profile. 
 
The ASCII “branch” is used to create profiles from Station, Elevation text files. 
 
The remaining “Leaves” are used to control the details of the Container and will not be covered here. 
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“Container” Cleanup 
While updating the profile “contents” is something that can be done 
at any time in the workflow, there is no way to clean up the 
“container” other than cutting a new profile.  If cosmetics (e.g. lable 
sizes and spacing) will be an issue it makes sense to clean them up 
prior to moving forward. 
 
If, for example, text labels are too small, but adequately spaced, 
changing the Global Text Scale Factor 
(InRoads>Tools>Options>>Factors) and re-creating the Profile may 
rectify the issue.  All text, cells, and linestyles sizes are multiplied by 
the Global Scale factors when InRoads creates graphics. 
 
 
Alternatively, hit the Preference button to see if there is a pre-defined Preference that may be more 
appropriate.  Try re-creating a profile with an alternate Preference.  This dataset includes an “_exaggerated” 
Profile preference which is designed for long full-length profiles and a Global Text Scale Factor of 40. 
 
Once we have a profile along the horizontal alignment, we can start building the vertical alignment (note: a 
surface is not necessary, but the profile is). 
 

Vertical Alignments 

Displaying Vertical Alignments 
Once we have a Profile along the parent Horizontal Alignment of a Vertical Alignment, we can display the 
vertical alignment.  The easiest way is to right-click on the vertical alignment. 
 
6. In the InRoads Explorer, 
right-click on a vertical 
alignment of the 
ha_canyon_rd. 
7. Select View. 
 

The Vertical Alignment is 
displayed in all the profiles 
that were cut along parent of 
the Vertical Alignment 
(ha_canyon_rd). 

Reviewing Vertical Alignments 
Again the Right Mouse button is the fastest way to get to this command. 
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8. Right-click on the same vertical alignment 
9. Select Review 
 
 
The Review Vertical 
Alignment form is 
invoked.  It looks and 
behaves very much like 
the Review Horizontal 
Alignment form. 
 

Annotating Vertical Alignments 
 
Vertical Alignment are Annotated with the Vertical 
Annotation command. 
 
10. Select InRoads>Geometry>View 
Geometry>Vertical Annotation to invoke the View 
Vertical Annotation command. 
 
This command acts upon a named Profile Set in the 
active CAD file.   
 
The Horizontal Alignment, Vertical Alignment and 
Profile Set controls work together to select what to 
annotate.   
 
The selected Horizontal Alignment will filter which 
Profile Sets show in the Profile Set list and limit 
which Profiles Sets can be graphically selected using 
the locator/target/picker button to the right of the 
Profile Set listbox. 
 
Once you have a Horizontal Alignment and Profile 
Set selected, simply pick the appropriate Vertical 
Alignment. 
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When multiple profiles for the active horizontal alignment exist in the CAD file, it is common to Annotate 
the wrong Profile Set.  The selected Profile Set graphics will have a highlight box around it.   
 
11. Click Apply and review the resulting graphic annotation. 
 

 
 
As always, all the graphical results are completely customizable.  Settings for the various types are under 
their respective tabs. 
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The Curves tab to the right shows a somewhat one of 
the more detailed setups in Vertical Annotation 
command. 
 
The Common Curve annotation can include any 
required information in any order and precision. 
 
The prefixes and suffixes for all of the callouts are 
definable under the Affixes tab. 
 
 

General administrative notes on how I set up this command:  
I’ve used three Named Symbologies for the entire scope of this 
command.  All the graphics go to the Align_Vertical level.  The 
“parent” Named Symbology is “Vertical Alignments” which 
has Left Center justification.  “Vertical_Align_Centered” is 
identical with Top Center Justification so that the curve 
annotation shows up centered in the curve.  The “Vertical 
Element” Named Symbology is the same as “Vertical 
Alignments” with explicitly defined color to differentiate the 
alignment from its annotation elements. 
 
 

 

Chapter Review 
We should now be able to: 
 Create Profiles. 
 Display Vertical Alignments. 
 Review Vertical Alignments 
 Display Vertical Alignment Annotation. 
Be able to provide additional debugging on Surfaces and Vertical Alignments 
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Chapter 7: Introducing Cross Sections 

 

Chapter Goals: 
 Understand what Cross Sections are. 
 Understand the data required to cut Cross Sections. 
 Be able to create Cross Sections. 
 Be able to display Cross Section Annotation. 

Cross-Sections are, in essence, a series of profiles cut relative to a path.  For typical cross-section sets, there 
is a consistent relative orientation and interval between the sections.  The orientation is related to the 
horizontal path by angle and width (left and right offsets).  Skewed and Custom section sets are also 
supported in InRoads, but are outside the scope of this introduction.   
 
Knowing this about Cross-Sections and being familiar with the Create Profile form, we might make some 
presumptions about the Create Cross Section form: 

 It will probably be similar to the Cerate Profile form 
 It will have additional controls to specify Interval and Width (Left and Right Offset) 
 Since Creating Cross Sections will create many Sections, there will probably be some controls to 

specify spacing between adjacent sections.  There might even be controls to set up spacing into 
Cross-Section sheets. 

 Judging by the differences between traditional Cross-Sections and Profiles there may be minor 
differences in the details of the Create Cross Section form. 

Creating Cross Sections 
Let’s take a take a look at the Create Cross Section form: 
1. Select InRoads>Evaluation>Cross Section>Create Cross Section. 
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The Create Cross Section 
form looks similar to the 
Create Profile form with 
identical “leaves” and some 
extras leaves and additional 
controls. 
 
On the General “leaf” we see 
the same sort of controls that 
we saw in Profile like Set 
Name, Vertical 
Exaggeration, and the 
Symbology frame for 
selecting which terrain 
surface lines to display.   
 
We also see the controls we 
predicted for setting the 
Interval, Left Offset and 
Right Offset. 

 
2. Click on the Source 
“leaf.” 
It is similar to the Source 
leaf in Profiles. 
 
The “Single Station” control 
allows you to key in a station 
or use the locator button to 
graphically pick the location 
of the station.  The section 
will use the Left and Right 
Offsets as defined in the 
General leaf. 

 
 
3. For the Source Alignment make sure it is ha_canyon_rd 
4. Hit Apply to see what happens. 
 
Like in Profiles, you are prompted to “Identify Location” for the lower left corner of the cross section set. 
 
5. Pick a location somewhere to the right or to the top of the plan data (to avoid writing over the plan data). 
6. Take a look at the cross-sections. 
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Cross Section Viewer 
The Cross Section View (InRoads>Evaluation>Cross 
Section>Cross Section Viewer) lists each Cross 
Section in each Cross Section Set.  
Notice that many sections were cut at even stations.  
The other sections are geometric cardinal point or 
superelevation event points (this can be toggled on or 
off in the Create Cross Section command). 
 
A Zoom Factor of 1.0 precisely fits the Section in the CAD window.  Less than 1 zooms in closer. 
Clicking on a station will quickly Zoom in that individual Section.  The keyboard Up or Down arrows can be 
used to “scroll” through the Sections.  Section 55+00 is shown below.  Notice the guardrail cells InRoads 
placed.  Additional Feature Styles, such as curbs and barriers, can be represented by cells by defining the 
Feature Style Cross Section Point display as an appropriate cell (or block). 
 

 
 
the Include Leaf 
Unlike the Include leaf in 
Profiles, having some data 
included by default is not 
necessarily a bad idea. 
 
Crossing Features are often 
very useful to have display 
(and typically do not slow 
things down noticeably).   
 
Leaving Components ON 
will cause Surface 
Components to show up in 
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Cross Section.  Again, this 
has great benefit without 
detriment and seldom needs 
any tweaking to look good. 
 
 
Projected Features, Annotation and Volumes can be included during creation of Profiles or can be added 
later using the appropriate commands.  Adding them later has the advantage of incremental, precise control 
of manageable “bites.”  Doing it from the Create form provides a nice “one-button” solution; and can be 
tweaked later. 
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The Limits leaf 
The Limits leaf allows 
manual limitation of 
Elevations and Station 
Ranges (frankly, Bentley 
should have left this on the 
Source tab). 

 
 
The Critical Sections Leaf 
The Critical Sections leaf is 
used to include sections in 
addition to those that fall on 
an event Increment. 
 
Critical Sections is used to 
include intrinsically 
geometrically significant 
points and previously 
defined event points.  The 
later Custom leaf is used to 
include skewed and 
manually defined sections).   

 
 
The remaining leafs are used to define the “Containers” and their spacing and sheeting. 
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Annotating Cross-Section slopes  
Proposed Engineering Model Quality Control 
As secondary as the graphics are to the model, the graphics that wind up on the Construction plans are still 
the fundamentally most important part of the InRoads Design/Publish workflow (as they are the legally 
binding documents). Few companies are moving dirt solely from the DTM model (a few use laser and/or 
GPS guidance on their earthmoving equipment and are saving millions of dollars, but they are still on the 
“bleeding edge”).  Since what is on the Cross Sections is what gets built, it is critical, especially on projects 
where Right of Way impacts are critical, to QC the cross-sections.  Additionally, even when the day comes 
when we skip creating 2D plans for 3D work (we beam our finished DTM to the Automated Scraper), typical 
sections and slope treatments are specified in the Design Requirements by slope and width relative to an 
alignment.   
 
Cross-Sections give us the ability to display our proposed road model in the same manner as was used in the 
definition in the Design Specifications. 
 
7. Take a close look at the any of the cross sections you just created. 
 
Can you tell what the side slopes are?  Do you have any idea as to the precise transverse slopes of the roads?  
Are there grade breaks between lanes? 
 
The Annotate Cross Section command provides the user the ability to satisfy the absolutely critical proposed 
surface Quality Control requirement: precise cross slope and width annotation/evaluation.  This can be used 
by the InRoads user to verify such things as transitions, superelevation and complex side slope solutions.  
The contractor can use the cross section sheets to verify slope stake reports before prior to sending the 
staking crew out to the field. 
 
Annotate Cross Sections provides a robust cross section annotation solution.  Some of the things it can do is: 

 Annotate slopes, widths of terrain surface segments 
 Annotate surface point elevations and offsets 
 Annotate offsets, elevations, Names, Descriptions, and Types of DTM Features 

 
8. Select InRoads>Evaluation>Cross Sections>Annotate Cross Sections 
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9. Hit Apply to see 
what happens (we’ll 
discuss some of the 
settings in a moment). 
 

10. Zoom in to one of 
the Cross Sections (or 
use the Cross Section 
Viewer). 
 
 
 

 
This screenshot of the 
Segments leaf shows 
how some of the 
details are defined. 
 

Features in Cross Section 
One of the fundamental benefits of the Intelligent Feature-based DTM is the that when InRoads is cutting 
Cross Section and displaying a Feature that is crossing the Section, InRoads knows exactly what Feature it is.  
We can tell InRoads (if our InRoads Administrator has not already done so) how to display that Feature.  If 
we tell InRoads that a Left Urban Gutter Feature should be displayed in cross section to scale (!) with a cell 
named Curb3L, InRoads will do it.  If we tell InRoads to display a Guardrail Type 3 Right to scale (!) with a 
cell named GR3_R, InRoads will do it.  We no longer have to do the mental and CAD gymnastics to do it 
ourselves, manually. 
 
What happens when the design changes?  How do we update all the cross sections?  We have to manually 
move everything we had done manually using CAD-only techniques.  Prior to InRoads v8, the only thing 

April 13, 2010  
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that InRoads could update automatically was the ground line.  EVERYTHING else had to be placed 
manually originally then manually update for every change in design.  With InRoads v8, InRoads can draw 
(virtually?) all of the special graphics itself the first time.  If the model changes, just 1) hit the Update Cross-
Section command and 2) hit the Annotate Cross Section command again.  You are done.  This can without 
exaggeration erase weeks from a design change/plans creation workflow. 
 

Cross Section:  Skews and Custom Sets 
The General leaf is used to set “global” width and interval.  This set can be augmented by including 
additional “regular” geometrically significant via the Controls>Critical Sections leaf.  What about skewed 
and irregular, even random, sections? 
 
The Create Cross Sections 
Custom functions allow the 
user to input irregular 
stations individually or in 
bulk.  
 
The Type listbox displays 
the supported methods of 
input.  By selecting a Type 
appropriate controls on the 
form are enabled. 
 

 
The “purpose” of this “leaf” 
is to build a list of special 
stations.  The list can be 
Saved to be Imported later. 
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The screenshot to the right 
shows how a Skewed section 
is added. 
 
After selecting Skewed for 
the Type, the user inputs the 
Station, Offsets and Skew 
Angle. 
 
Hitting the Add button adds 
the input values to the 
Custom section list. 

 
 
Setting the Type to Station Range enables controls for any number of 
sections with identical offsets and skews. 

While these two methods are useful, it’s unlikely that these methods are 
the best methods for inputting the section data.  A more streamlined 
method defines the “Section” list from graphics and is described below. 
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Sections from Graphics 
When the Custom Type is set to Linestring the Graphics button is enabled, but only if a Selection set is 
currently active. 
 
The 
screenshot 
to the right 
shows a 
Selection 
Set of 
three 
random 
linestrings.  
The 
Graphics 
button is 
enabled 

 
 
Quirk: If you invoked the Create Cross Section command without an active selection set, you have to exit the 
command, create a selection set, and invoke the command again. 
 
The list to the right is created when the “Graphics” 
button is hit. 

Selecting any of the sections in the list allows the 
user to edit the information.  Hitting the Update 
button updates the list. 
 
 
Creating and editing a custom list will invoke a 
prompt to save the list in a file that can be loaded 
later. 

 
 
Note: when a custom list exists the General Offset and Interval stations set in the General leaf will be 
ignored.  In order to generate a set of sections with custom stations intermixed with regular stations, the all 
the stations, regular and custom must be included in the Custom station list.  There are a couple of ways to 
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do this: generate the “regular” stations via the Station Range Type in the Custom leaf or to generate all the 
Cross Sections as needed and as necessary with the “Planimetric Display” toggle ON (as shown below).  
Once all the sections are drawn, create a Selection Set of the Planimetric graphics and import as a Custom 
list. 
 
 

 
 
 
 
 
 
 
 
 

 

Chapter Review 
We should now be able to: 
 Understand what Cross Sections are 
 Understand the data required to cut Cross Sections 
 Create Cross Sections. 
 Display Cross Section Annotation 
Provide additional Surface debugging. 
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Chapter 8: InRoads XML Reports 

 

Chapter Goals: 
 Understand how “generic” XML Reports work 
 Be able to create InRoads XML Reports. 
 Understand how XML Styles work. 

Understand how to Share Report Data

XML has been the hot topic in the internet world for a few years now.  To oversimplify it’s a data structure 
standard that uses standard text as opposed to binary formats.  The InRoads developers see its benefits and 
actually do a lot of things “under the hood” in XML (including drafting notes, the Preference file, the 
Template Library and the Roadway Design File.).   
 
The XML Reports commands and the XML Report Viewer have replaced the original, proprietary and “old 
technology” InRoads Reports with “new technology” XML Reports.  Additionally a number of specific 
XML report generators are scattered throughout InRoads replacing the old “niche” reports.  While this 
chapter focuses specifically on the XML Reports commands and the XML Report Viewer, the concepts are 
the same for all xml reports. 
 
XML Reports provide a number of improvements over the older reports.  The primary improvements relative 
to the InRoads data model are that the XML Reports functionality takes full advantage of the “intelligence” 
of the InRoads v8 feature-based DTM and custom formatting reports now conforms to a broadly accepted 
standard.   

XML Reporting 
XML Reports have a number of advantages over the older InRoads report functionality including: 

 XML Reports take full advantage of the v8 DTM intelligence 
 Industry-standard extensible format 
 Text-editable data reports 
 Text-editable formatting templates (“Stylesheets”) 
 Easier report “tweaking” 
 Extensive customization with knowledge of XML/XSLT 
 Easier to manage Stylesheets than proprietary binary libraries 

 
Perhaps the most important qualitative difference is that the XML Reporting functionality was written after 
the DTM became intelligent.  Whereas previously there was not much point to provide much interaction with 
the DTM, XML Reports take full advantage of the intelligent DTM.   
 
Take Stakeout Reports for example.  The New Stakeout Reports read from the Geometry Project and the 
Surface.  With the older technology an intermediate report was during roadway design in the middle of the 
engineering process and could not reflect any detail engineering.  The new XML report information is 
derived directly from the DTM at the time of the report.  Roadway Designer can be used to create a proposed 
roadway like before.  But now, any small scale editing using, for example, the Surface Editing tools, is 
reflected in the DTM and, therefore, in the Reports.   
 
Whereas a Stakeout Report created from the old InRoads Roadway Model binary file was rightfully subject 
to a certain amount of suspicion, the XML Stakeout Report is now derived directly from the “live” Digital 
Terrain Model.  It is dramatically more difficult to get an error from new technology. 
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XML data files and Stylesheets 
Generating XML Reports is a two step process.  The first step is to create an XML data file.  These files are 
text files containing data required for the final reports but formatted in XML format according to an 
“InRoads schema.”  While still “text”, the format is useful for sharing data among software rather than 
people. An example is shown below 
 
 <?xml version="1.0" encoding="iso-8859-1" ?>  

- <InRoads outputGridScaleFactor="1.000000000" 
inputGridScaleFactor="1.000000000" linearUnits="Imperial" 
angularUnits="Degrees" gauge="4.708333333" 
equilibriumConstant="4.650000000"> 

- <GeometryProject name="Alignments" description="Gap/Connector 
Alignments" file="Q:\SR-
125\Gap_Conn\Design\InRoads\Geometry\SR54.alg" 
lastRevisedDate="9/27/2002 8:10:58 AM" 
lastRevisedBy="MorrisG"> 

- <HorizontalAlignment name="BR" style="Caltrans 500" 
description="SR54 LINE" curvatureDefinition="arc" 
lastRevisedDate="9/4/2002 5:45:08 PM" lastRevisedBy="jam" 
fromFeature="false"> 

- <HorizontalElements> 
- <HorizontalLine style="Caltrans 500" 

length="440.948749041" direction="0.849437196"> 
- <Start style="Caltrans 500" 

northing="557390.379000000" 
easting="1926853.038100000" 
elevation="0.000000000" offset="0.000000000" 
type="POB"> 

 
 
The second step is to transform that data into something legible.  This is done by applying a stylesheet. 
Stylesheets are files conforming to a somewhat complex language called XSLT for eXtensible Stylesheet 
Language: Transformations.  They are text files typically having an filename extension of .xsl.  Stylesheets 
transform the data from the “formatted-for-software” XML format to a wide variety of other formats 
including plain text, HTML, and other XML formats.  While a somewhat complex language, it is industry 
standard and “tweakable” with a text editor. 
 

XML Reporting in InRoads 
Generating InRoads XML data files 
Text Files tend to be slow to read and XML reports tend to be large.  Because large text files take a long time 
to process it is advantageous to tailor the scope of the data in an XML file to the ultimate use of the 
anticipated final reports.   
 
It is possible to create a single InRoads XML Data report from which all final reports can be generated, but 
this file would be unwieldy.  Instead InRoads uses a number of different “Type Generators.”  The controls 
differ from one Type to another, so instead of having one complicated form to generate a number of different 
XML data report types, each type is a separate menu item with a different form. 
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11. Select InRoads>Tools>XML Reports 
The XML Report Types are shown. 
 
 

12. Select InRoads>Tools>XML Reports>Geometry 
 
Geometry Reports 
 
13. Select1 ‘ha_canyon_rd” as the 
Horizontal Alignment.   
 
The various checkboxes allow 
inclusion of additional objects into 
the XML file (such as vertical 
alignments).  The primary harm of 
including unnecessary data is that 
you get a larger, slower file. 
 
For our purposes we can leave all 
checkboxes blank. 
 

14. Hit Apply. 
 
You will get a message box urging you to select a default stylesheet for this type of report.  The InRoads 
Report Browser is then invoked. 

                                                 
1 (remember: there are a number a number of ways to select the Horizontal Alignment(s): you can key in the name in the Include: 
field or use the Filter button (the cursor must be in either of the Include: fields), Locator button…) 
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As you can see the raw XML file is neither pretty nor particularly useful. 
15. Select Geometry>HorizontalAlignmentReview.xsl in the Library pane.   
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Notice the pretty colors and background image (of a fence!). 
 
16. In the Report Browser select Tools>Format Options 

 
 
The Format Options form is invoked.  
Here the format and precision of the data 
in the report can be changed “on-the-fly.” 
 

 
 
17. In the Report Browser Library Pane select HorizontalAlignmentReviewASCII.xsl 
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This is the exact same data in the same order, but without the HTML formatting.  Stylesheets not only extract 
and arrange data, but can transform it into just about any format. 
 
18. Click on HorizontalElementsTable.xsl 
 

 
 
Same data, completely different look. 
 
19. Click on a number of other Horizontal Geometry stylesheets (those starting with 
HorizontalAlignment*). 
20. Click on a different type of stylesheet. 
 
Note the variety and that sometimes you get nothing or nonsense.  Each stylesheet was written for a 
particular set of data.  The source XML file may or may not match well or at all. 
 

Other Reports 
The Station Offset, Station Base, Clearance, and Stakeout Reports are very similar in that they have 
essentially an “origin’ object and “target” objects that need to be defined.  The “origin” object is often a 
centerline.  The “target” objects can be other alignments, linear features such as edges of pavement and 
ditches, and point features. 
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We will generate a Station Base Report for Guardrails. 
 
21. Select InRoads>Tools>XML Reports>Station Base 
 
The Station Base Report form has four 
“leaves.” 
 
The General leaf is used to select the 
“source” or “origin” alignment or 
feature.  This is the object from which 
stationing is based and interval 
calculated. 
 
22. Select “ha_canyon_rd” as the 
Horizontal Alignment. 

 
 
23. Select the Include leaf 
 
This page is used to select where points 
are calculated for inclusion in the report. 
 
Whereas the Geometry reports 
automatically include cardinal points, 
this does not. 
 
24. Toggle ON:  Horizontal On-Alignment 
Points; Cardinal Points of Selected 
Alignments/Features, and specify an 
Interval of 100’. 
 
 
25. Select the Horizontal Alignments leaf
 
This page is used to include horizontal 
alignments as report targets. 
 
The Include field and filter behave like 
the others we already used. 
 

26. Leave these fields blank. 
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27. Select the Features leaf 
 
This page is similar to the Horizontal 
Alignments tab as it is used to include 
Surface Features as report targets. 
 
28. Ensure that existing_MesaPark is 
the active Surface. 
29. Select the Guardrail_Left and 
Guardrail_Right features. 
 
 

30. Hit Apply. 
 
31. You may get a message box prompting you to select a default Station base report.  If so, click OK. 
32. In the Report Browser Library Pane select StationOffsetTransverseFeature.xsl 
 
 

 
 
33. Try also the other StationBase* stylesheets. 
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How the Report Browser Works 
How does it all work?   
The Library Pane shows the folder (and sub-folders) specified in the Project Defaults 
Style Sheet (.xsl) field. 

This folder can be changed by selecting Tools>Style Sheet Root… 
 
The folders and files shown in the Library Pane are simply the folders in file in the Style Sheet Root folder.  
Folders and files can be renamed and added and reorganized into something that better fits your organization 
(although customizing files in the product delivery folder is risky.  It is better to copy the entire folder to a 
new location prior to fooling with things). 
 
The .xsl Stylesheets refer to a format.xsl, which is how the Format Options form interacts with the reports to 
change the precision and unit formats.  The Stylesheets also refer to formatting themes, found in the _themes 
subfolder. 
 
The Report Pane in the Report Browser is essentially the same as that in the generic Internet Explorer. 
 
The Report Browser allows the user to save the source data XML report (the XML File Type option) and the 
resulting report as an HTML file.  One note about the HTML file:  the HTML file does not contain all the 
information required to make the pretty report you see in the browser.   
 
The report to the right is the Horizontal 
Alignment report without access to the 
“theme” files.  The content is valid, but 
some of the cosmetics are missing (like the 
colors and fonts and the background 
image).   
 
This “loss” isn’t very critical in this case, 
but it is important to be aware that a single 
html file is just part of the bigger picture. 
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Sharing Data 
The best way to share data between InRoads users is to share the InRoads data files. 
 
LandXML files are designed to share data between different design software platforms.  The InRoads 
LandXML Translators are found at InRoads>File>Translators>LandXML. 
 
XML reports can contain a great deal of data in an InRoads-defined schema.  Non-InRoads users proficient 
in XML and XSLT can extract the data into a variety of formats. 
 
HTML files, as mentioned above, provide tailored reports, with stripped-down formatting. 
 
MHT files are one way to capture the content and cosmetics of the InRoads report in a single file.  It works 
with Internet Explorer v6.0 or above.   
 
Open a saved InRoads htm report in Windows Internet Explorer.  It should look like it does in the InRoads 
Report Browser.  From the Menu Bars select File>Save As… invoking the Save Web Page form 
 
The bottom of the form show the File 
Types available: 
 
“Web Page, complete (*.htm.*.html)” 
will provide identical look and feel but 
creates a file and a subfolder with a 
variety of supporting files copying from 
external references as necessary. 
 
“Web Archive, single file (*.mht)” is the “single file solution.” 
 
“Web Page, HTML only (*.htm,*.html)” provides a single file without copying linked files. 
 
Text File will be most universal, though you will lose formatting. 
 
 

 

Section Review 
We should now be able to: 
 Understand some of the advantages of the new XML Reports. 
 Understand how “generic” XML Reports work 
 Create InRoads XML Reports. 
 Understand how to Share Report Data 
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Chapter 9: Drafting in InRoads 

Overview of Drafting Technologies 

Graphics “Updates” 
Graphic elements in InRoads as well as object Annotation is a result of InRoads (internal) queries to its data 
files.  The elements and any annotation is a single-instant “snapshot” of the InRoads data files.  The element 
or the text is not aware that InRoads exists; it doesn’t “touch base” with InRoads to make sure it isn’t 
obsolete.  It’s a one way street: InRoads spits out graphics; graphics do not check up on InRoads. 
 
Some commands update some but not all of the graphics when it changes the underlying “database” 
information.  Given that changing the “database” information does not update all the graphics all the time 
dictates that the user understands how to ensure that all the graphics are up to date.   
 
Geometry graphics and annotation can be updated by re-running the original View Geometry commands.  
Surface information is design tends to be displayed three times: plan, profile, and cross-section.  Keeping the 
data in these three views synchronized is facilitated by the three Update (Features) commands in Plan, 
Profile and Cross Section.  Surface Annotation is updated by re-running the respective View commands. 

Update Features  
(This revisits commands we’ve already used in this book, for emphasis.) 
 
Surface Features have parallel “View Managers” for Plan, Profile, and Cross Section: 

Surface>Update 3-D/Plan Surface Display… 
Evaluation>Profile>Update Profile 
Evaluation>Cross Section>Update Cross Section 

 
One intent for the three commands is to facilitate object display in all three views.  Displaying, turning off, 
and refreshing all the surface “engineering data” in the project can be done from this command.  If you re-
run a corridor the profiles and cross sections data can be refreshed with these commands.  If you are given a 
new surface representing underground utilities, use these commands to display the new Plan information and 
add the new data to your Profiles and Cross Sections. 

Feature Annotation 
Every feature in the database can be displayed in Plan, Profile, and Cross Section with “parallel” annotation 
commands (InRoads>Surface>View Surface>Annotate Features, InRoads>Evaluation>Profiles>Annotate 
Features in Profile, InRoads>Evaluation>Cross Sections>Annotate Cross Sections).  All of the properties of 
the feature are available for annotation.  These commands tend to be “one-button: global results”: excellent 
for in-process labeling and review, but typically requiring cleanup (text “collisions” and overwriting) prior to 
plotting or sharing.  Individual callouts are best handled via Drafting Notes. 

Annotate Profile 
Profiles have a number of Annotation commands (in chronological order): 

 Annotate Profile 
 View Vertical Annotation 
 Annotate Drainage Profile 
 Annotate Feature in Profile 
 Place Profile Note (we’ll explore the Drafting Notes technology later in this chapter). 
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Annotate Profile was developed at the dawn of InRoads to label those things that the industry required on 
Profile sheets, such as Superelevation Diagram, Curve Diagrams and Mass Haul Diagrams. The newer 
commands tend to be more specific; Annotate Profile can be considered something of a “leftover bucket.”  If 
it’s not in a newer functional command, it’s in the Annotate Profile command. 
 

Plan and Profile Generator 
InRoads>Drafting>Plan and Profile Generator is perhaps the single most complex command in InRoads.  Its 
purpose is to automate the heretofore manual processes of setting up sheets, such as view rotation and 
reference clipping.  An example of where it can excel is for very large roadway projects or projects that 
require “sheet shifting.”  If you set up a project using P&P Generator and then every sheet needs to be shifted 
up or downstation you’ll be happy you used P&P Generator. 
 
My general recommendation for this command: teach it only to the people who currently set up your sheets.  
It takes a few projects to get the necessary “feel” for the details of the command.  If you don’t have to set up 
more than a few big projects a year, learning this command may never “pay off”.  If you have many, it is best 
to get one or two people “really good” at it.   
 
If you have not set up sheets manually, it’s a good idea to set up a few sheets (with rotated views and 
reference files needing clipping) to get experience with the complexities of sheet setup. 
 
Due to the complexity of the command and the small audience for this command, I will refer you to 
Bentley’s Help and on-line resources for this command. 
 

Drafting Notes 
The purpose of the InRoads Drafting Notes is to greatly streamline the manual drafting notes process.  Most 
drafting notes consist of two parts: a particular formatting style, including leaders, text, symbology; and 
content.  This manual workflow may consist of 

 Defining proper symbology 
 Selecting the appropriate CAD Leader/Text Tool (e.g. Place Note) 
 Clicking the location of the start of the leader (if necessary) 
 Clicking the location of the note. 
 Identifying the object 
 Looking up the object’s properties 
 Typing the Properties (including Prefixes, Suffixes, etc.). 

 
Hopefully, your deliverable standards require a finite number of combinations of cosmetics and content.  In 
essence, each Drafting Note is a definition of the style and the content required.  In theory, you (or your 
InRoads administrator) would have created a Drafting Note for each unique callout requirement.  The user 
would then select the correct Drafting Note, click the object and then select the location of the note.  That’s 
it:  the symbology, format, and the object’s properties would be automatically be defined.  The object 
properties (the information most likely to require the most amount of time and mostly to be mistyped) is 
instantaneously and automatically pulled from the InRoads data. 
 
The table below summarizes the effort required to place notes.  The bold rows indicate the more time-
consuming steps.  Notice that the InRoads Drafting Tools eliminates the user having to do anything more 
complicated than picking Note types, objects or locations. 
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Required Step for each callout Manual Cells 
w/Data 
Fields 

InRoads 
Drafting 

Notes 
Defining proper symbology 1   
Selecting the appropriate CAD Leader/Text Tool (e.g. Place Note) 2 1 1 
Clicking the location of the start of the leader (if necessary) 3  2 
Clicking the location of the note. 4 2 3 
Identifying the object 5 3  
Looking up the object’s properties 6 4  
Typing the Properties (including Prefixes, Suffixes, etc.). 7 5  
 
The screenshot below shows a cross section note.   
 

 
The note was created by the following four clicks which take about 10 seconds combined: 

 Select the Pipe Length & Slope note. 
 Hit Apply. 
 Select the Pipe near the leader point. 
 Place a data point <D> at the note location. 

 
Consider the steps and time required to do this manually, in particular finding and transcribing the data. 
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Drafting Notes Example 
Note File Structure 
 
1. Select InRoads>Drafting. 
 
The Drafting Menu consists of the Plan and Profile Generator and the Drafting Notes commands which are 
broken up functionally into “Place”, “Update” and “Move” commands.  The Notes are further broken up by 
“View”: Plan, Profile, Cross Section; and Alignment Intersection, primarily to control how the cursor reads 
coordinates (absolute position vs. relative to a profile or cross section origin) and to include some 
functionally specific controls on the appropriate forms. 

 
 
 
2. Select InRoads>Drafting>Place Plan Note. 
 
This launches the Place Plan Note form.  This is 
similar to the Place Profile Note and Place Cross 
Section Note form (the difference, again, is primarily 
how InRoads controls and interprets the cursor 
during placement). 
 
The Place Plan Note form does include controls to 
change the Active Horizontal Alignment and 
Surface, if necessary (the appropriate geometry or 
surfaces are implied or derived for the Profile and 
Cross Section Notes). 
 
 
The “Note File” frame shows the active “.dft” file which should have been set in the “InRoads>File>Project 
Defaults” command.  To change the Notes file select the form’s File>Open menu item. 
 
The Note file (*.dft), like many InRoads files, is an xml file.  The user content is a “tree” as evidenced by the 
“plus sign” (+) to the left of the “folders” with content.  The folder organization of the notes is flexible and 
up to the user or the administrator.  The KYTC Note file is a customized extension to the default file 
delivered by Bentley. 
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Expand all the objects in the Note file. 
 
The highest level folders parallel the Notes “View 
type”: Plan, Profile, Cross Section and Alignment 
Intersection. 
 
Lower level folders are for organizational clarity and 
more likely to vary from agency to agency. 
 

  
 
Alignment Commands 
Let’s prepare our .dgn file for some alignment notes.   
 
3. Clean up the plan 
graphics as necessary.  
Leave the graphics as you 
care to have them 
(references on or off, etc); 
our emphasis will be on 
horizontal alignments 
(specifically, I-65, Grade 
Line and Grade Line 
Connector). 
 
 
 
 
4. Select the Alignment Name note. 
 
Note: most of the Notes automatically read the 
graphics/database for the appropriate label.  The 
Alignment Name note snaps the leader to the 
selected graphic, but labels the name of the active 
alignment.   
 
Use the Horizontal Alignment listbox or pickbox to 
select the intended alignment. 

5. Select the Locator button to the right of the 
Horizontal Alignment listbox.  
 
6. Place a Data button <D> on the Grade Lane Connector 
as shown to the right. 

April 13, 2010  9-15
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7. Accept the selection. 
8. When the Place Plan Note form returns hit Apply and 
follow the prompts: 
 
9. At the “Identify Anchor Point” prompt, select a point on 
the Grade Lane Connector alignment from where you want 
the leader to start. 
 
10. At the “Identify Note Location” prompt select a 
point for the note. 

The command loops, returning to the “Identify 
Anchor Point” prompt. 
 
11. Click a new location to continue or reset <R> to 
return to the Place Plan Note form. 
 
A Note’s Settings and Controls 
The Existing and Proposed subcategories have no special meaning to InRoads, they may be segregated that 
way based on differing symbology.  How can we figure out what each Note looks like other than placing 

each one?  The Settings button and the  button open up the details of the Note definition. 
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The Note box shows the data layout of the note. 
 
 
 

The “Inserts” box shows the values available for use, 
including General, Geometry, Surface, 
Storm&Sanitary, and User Text fields.   
 
To the right of the notes box are calculator buttons to 
include Mathematical functions and calculations in 
the note. 
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Below the Notes field are a number of controls to 
facilitate formatting.  

 
 
Often Notes have text above and below the leader 
line, the {Delimiter} field shows the location of the 
leader line and is input by selecting the Delimiter 
button.   
 
The form to the right shows an example of a Note 
with a delimiter. 
 
The Settings button launches the Settings form, which 
contains symbology definitions and other specifics about 
how the Note acts and looks. 

 
 
12. Place some of the other Plan>Proposed Notes. 
13. Close the form when done. 
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Alignment Intersection Notes 
 
The Place Alignment Intersection Note is an 
interesting example of Drafting Notes.  Although it’s a 
plan view note InRoads needs to prompt for two 
alignments, so a separate command was written. 
 
The alignments are identified with user prompts as 
opposed to an Active Alignment listbox. 
 
14. Select Drafting>Place Alignment Intersection Note.
Intersection method will only label the intersection 
point.   
 
Offset method will label any point on an alignment 
relative to both alignments. 
 
15. Zoom in to the intersection of I-65 and the Grade Lane Connector. 
16. With the Method set to Intersection, select the Align – Align Stationing Note. 
17. Hit Apply. 
18. At the “Identify first horizontal alignment” prompt, select either I-65 or the Grade Lane Connector 
alignment.  
19. At the “Accept/Reject” prompt, place a Data point <D> to accept the alignment. 
20. At the “Identify second horizontal alignment” prompt, select the other alignment. 

21. Accept the selection. 
22. At the “Identify quadrant” 
prompt, place a Data point <D> 
anywhere. 
23. At the “Identify Note 
Location” prompt, place a Data 
point <D> where you want the 
note.  
 
The command loops. 
24. Reset to return to the form. 
 
The difference between the two 
notes to the right is the order the 
alignments were selected. 
 
25. Change the Method to Offset. 
 
This allows a dual-station note anywhere along a second alignment. 
 
Place both note types at the north end of the Grade Lane alignment. 
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The top Note is the Align – Align Stationing Note, the bottom is Align-Align-Offset. 
 
Profile and Cross Section Notes 
 
Profile and Cross Section Notes look and behave like the plan notes.   
 

 
 
26. Place Notes on your Profiles and Cross Sections (if you’ve erased them, create new ones). 
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Move Note 
Moving Notes with CAD commands does not hold the anchor point.   
27. Use InRoads>Drafting>Move Note to move the Note while holding the anchor point. 
 
 

 
 
 
 
 
 
 
 





Appendices 

© 2004-7 Civil XLR8    April 13, 2010  10-1

 

Chapter 10: Volumes 

Chapter Goals 
 Understand what InRoads needs to calculate Volumes. 
 Understand how the different Volume Methods. 
 Know the advantages and disadvantages of Triangle Volumes and. be able to calculate them. 
 Understand the advantages and disadvantages of Grid Volumes. 
 Understand why we perform End Area Volumes calculations. 
 Understand how to include subgrades in End Area Volumes calculations. 
 Understand why and how to use End Area Volumes calculations Adjustments. 

 
Given two surfaces, InRoads can compute the cut and fill volumes between them.   
 
This screenshot to the right shows the 
simplest and most mathematically accurate of 
the volume methods: Triangle Volumes.   
 
All InRoads needs are the Original and 
Design Surfaces and the Cut and Fill factors. 

Triangle Volumes 
Let us compute the Cut and Fill volumes along canyon road between the current design and a superelevated 
design.  
 
1. Open the a design surface for canyon road.  It is named “canyon_future_4lane.dtm..”  It might be 
hidden in a subdirectory of the training directory.   
 
We can now just calculate the volumes, but good technique demands that we do a little evaluation of this 
surface before performing work from it.  The surface name tells us a little about the surface.  Where does the 
surface lie horizontally?  Where is it vertically?  How does it relate to the “existing” MesaPark surface?  
How can you tell? 
 
Once you have verified that a Volumes evaluation is a reasonable task to perform, do so. 
 
2. Select InRoads>Evaluation>Volumes>Triangle Volume 
3. Select existing_MesaPark for Original Surface and canyon_future_4lane for the Design Surface.   
 
If you get these backwards then the Cut and Fill volumes will be reversed. 



Exploring InRoads 

 All Rights Reserved.  Copies are Illegal. ©2004-7 Civil XLR8 10-2 

 
4. Hit the Add button. 
5. Hit Apply. 
 

The first time this report is run you may get 
the following message box: 
 

 
 
You will then get the Report Browser which will look like this: 
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6. Click on 
Evaluation>TriangleVolumes.xsl 
to make it pretty: 
 

 
 
7. Clicking on File shows the menu options to Save the file or Print 
 

Volume Method Comparison 
The InRoads Volumes commands are found 
under InRoads>Evaluation>Volumes. 
 
 

 
 
The Triangle method of volume calculation is mathematically perfect.  Every discontinuity (triangle vertex) 
in both surfaces is used in the volume calculation.  The challenge to this method is that the results are 
extremely difficult to hand check.   
 
Traditionally, roadway volumes are calculated by Cross Section End Areas, not because they are more 
accurate (they are not), but because it is easy to do hand calculations directly from the construction 
documents.   
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. 

 
InRoads offers a Grid Volume method which reads elevations from both surfaces along a grid interval.  
There resulting mesh of 4-sided prisms provides the ability to perform hand checks.  A large grid interval can 
take less time to process than the Triangle method.  The accuracy of the results are approximate, sometimes 
outside acceptable tolerances.  Unless you are performing hand checks, there is little reason to use this 
option. 
 
Triangle Volume by Station provides the ability to correlate triangle volumes to cross section sheets.  This 
method reads the triangles between the cross sections whereas the End Area Volume method simply 
averages the bounding sections. 
 
Since the first Triangle and Grid methods are straightforward and the On-line help is actually pretty good for 
these commands, we well restrict our detailed technical discussion to the End Area Volumes. 
 

End Area Volumes 
End Area Volumes is the one major command in InRoads which performs calculations from graphics.  End-
Area Volumes does NOT read from the InRoads files (DTM’s, ALG’s2, etc.) during its calculations.  Given 
a “mystery” CAD file with InRoads Cross Sections on it, we can generate End Area Volumes from it
 
End Area Volumes works from the graphics of a Cross Section set.  The “Ends” that the Volumes are 
calculated from are the Sections in the Cross Section set.   
 
Create Cross Sections along Canyon Rd 
 
8. Create Cross Sections along Canyon Roads using the existing and design DTM’s.  Explore the 
Preferences if the Default Preference is not suitable. 
 
Once a suitable Cross Section Set is available, Calculate End Area Volumes: 
 
9. Select InRoads>Evaluation>Volumes>End Area Volume. 
 
The Original Surface and the Design Surface are determined from the Surface Properties. 
 
10. Hit Apply. 
 

                                                 
2  If “Correction for Curvature” is toggled ON, it will read the alignment curves to adjust volume calculations. 
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Cut and Fill shapes are drawn in the Cross Sections and are annotated. 
 

 
 
A closeup of the right side of the above 
section shows area totals for Cut Area, 
Fill Area and areas for the proposed 
surface components (curb, sidewalk, 
pavement and shoulder pavement). 
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As the Create XML Report checkbox was toggled ON an XML Report was created.   
11. Select the Evaluation>EndAreaVolume.xsl stylesheet to make it legible. 
 
 

 
 
How do the End Area Volumes compare to the Triangle volumes?   
 
Notice how the proposed surface components affect cut and fill areas: 
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12. Examine the Sections and Volumes. 
] 
There are a number of Cross Sections where the Design Surface 
intercepts the Existing Surface vertically, which is incorrect and skews 
the results.  A primary cause for this is the daylight point occurs outside 
the section.   

To correct the errors, create new Cross Sections where the Left and 
Right Offsets are wide enough to include the widest part of the design 
surface and reCalculate the Volumes. 
 
Adjustments 
End Area Volumes is designed to parallel the standard volumes methodology that Civil Engineers have been 
using for decades.  Since End Areas are sampled only at relatively sparse intervals at limited widths, a lot can 
happen to the surface that does not show up on the sections.  Adjustments can be made to the volumes via 
the Adjustments tab on the form. 
 

“Leaf” Explanation 
Unsuitable Material Allows setting different stripping depths to be defined inside a closed feature 

or along the alignment by section range. 
Classifications Cut and Fill Factors by surface or component. 
Compaction/Expansion Cut and Fill Factors by section range 
Added Quantities Allows Cumulative Cut/Fill Volume to be adjusted at a given station for off-

section “events” (borrow pits, ponds, wastage). 
Volume Exceptions Allows stations to be exempt from volume calculations, used for roadways not 

on grade (bridges) 
Forced Balance Provides a cut/fill total at the station (often used in phased construction) 

 
The adjustments can be saved in a Control file for use for subsequent calculations. 
 
The Annotation leaf is used to control the appearance of the cut, fill and mass ordinate shapes and labels. 
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Chapter Review 
We should now: 
 Understand what InRoads needs to calculate Volumes. 
 Understand how the different Volume Methods 
 Know the advantages and disadvantages of Triangle Volumes and. be able to calculate them. 
 Understand the advantages and disadvantages of Grid Volumes 
 Understand why we perform End Area Volumes calculations. 
 Understand how to include subgrades in End Area Volumes calculations. 
 Understand why and how to use End Area Volumes calculations Adjustments. 
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Chapter 11: Appendices 

 Locks 
MicroStation has a number of “Locks” which affect how commands act.  InRoads also has a number of 
Locks which affect how its commands act.  Hint: You should always have the InRoads Locks dialog box 
visible (SC>Tools>Customize>>Toolbars or Right-Click the Toolbar area of the InRoads Explorer).  This 
makes troubleshooting much easier when what you expect to happen doesn’t.   
 

 

Active Filter/Filter Lock 
Filters are pre-defined or user-defined groups of features to include or exclude with a command.  For 
example a filter may include only Proposed or Design Features in a DTM, excluding everything other 
feature.   
 
Used extensively with the Surface View and Edit Features commands, filters limit make it dramatically 
easier to exclude irrelevant or unnecessary data from the “working data.”  For example,  the Fillet Feature 
might only be used on “Curb_back” features.  Defining and Enabling a “Curb_back Only” Feature Filter will 
allow the Fillet Feature command to only select Curb_back Features. 
 
The drop-down list at the left of the Locks toolbar is the Active Filter, which is honored only when the first 
tool, Feature Lock, is ON. 
 
Features to be displayed with Filter Lock OFF: Features to be displayed with Filter Lock ON: 
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Style Lock 

 
The Style lock enables or disables the “customizability” of surface display.  With the Style Lock OFF, when 
selecting a command which displays surface features a form is invoked from which the user can accept or 
change a myriad of settings.   
 
With the Style Lock ON, the form is not invoked and the graphics are displayed immediately.  The settings 
used are predefined, usually derived from a command Preference matching a property of the surface being 
displayed.  Leaving the Style Lock ON can speed production and automate standards. 
 

Pen/Pencil Mode and Delete Ink Lock 
 

Pencil, Delete Ink On 

 
 

Pen, Delete Ink Off 

 
 
InRoads graphics are derived from data models in the various files (surface, geometry, etc.).  This allows 
automatic deletes and updates of InRoads-placed graphics (no “CADD-only” graphics are deleted). 
 
Pen/Pencil and Delete Ink Lock 
Pen/Pencil Lock affects InRoads’s automatic refresh of elements.  Analogous to using Pen and Pencil on 
Paper, graphics placed with the Lock set to Pencil are more readily erased than with the Lock set to Pen.  
Pencil is almost always erased when new information is displayed; no leftover graphics tend to remain.  Pen 
is useful when you want InRoads to leave graphics previously placed graphics alone.  An example is when 
wanting to compare or plot multiple scenarios, such as alternative radii on between tangents. 
 
Delete Ink is used to delete all existent graphics relevant to the current InRoads command.  
The image below shows three radii that were used on a curve.  The graphics were generated with Pen Lock 
ON, Delete Ink OFF.  If Pencil Lock were ON or Delete Ink ON, only the most recent radius (and thus the 
only radius stored in InRoads) would be displayed. 
 

 
 
 
 



Appendices 

© 2004-7 Civil XLR8    April 13, 2010  11-3

For a complete discussion of the Write Lock, the Pen/Pencil Lock and Delete Ink, see the Help 
documentation.   
 
A good place to start is with the following setting: 
 Write Lock: ON  

Pen/Pencil: Pencil 
 Delete Ink: Off 
 

Locate Graphics/Features 
 

 
When using some of the Design Surface commands, the designer may want to select a CAD graphic for input 
or select a Feature in a Surface.  The Graphics/Features Toggle allows the designer to designate which he 
intends to use.  Commands honoring this toggle display the active mode in the command form. 
 

Snap Lock 

 
Point Snap Mode: when placing points ON snaps to the nearest InRoads point; OFF takes the coordinate 

from the Data Point (cursor, <D>). 
Element Snap: when ON snaps to the nearest element (often useful for getting bearings). Note Point Snap 

and Element Snap are mutually exclusive. 
Snap Off: disable both Point and Element snap. 

Station Lock:  

 
snaps to even (divisible by 100) stations on alignment. 

Report Lock:  

 
when ON functions supporting reports generate reports. 
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